Resolved Problem with PCSX-R and X360 Wireless Controller - Stuck triggers

Discussion in 'Mac and PC Games' started by Tigerman82, Apr 1, 2013.

  1. Tigerman82, Apr 1, 2013
    Last edited: Apr 2, 2013

    Tigerman82 macrumors 6502

    Joined:
    Jul 27, 2010
    #1
    So I decided to install PCSX-Emulator and play some Final Fantasy VIII. I have a Mid-2010 iMac and OS X 10.8.3. I was tempted to buy a 3rd party PS gamepad but then I remembered that I have a Microsoft X360 Wireless Controller (for Windows) that I've used to play the Arkham-games in Win 8. I did a little research and managed to connect it to OS X via Tattiebogle-driver. In PCSX-E Preferences I configured the keys of the controller and everything went fine.

    Unfortunately a problem occured when I played FF8 which made playing it difficult. I started noticing it when the X-key wouldn't always work (in the beginning of the game you have to hit it constantly to get the dialogue moving forward). I then noticed that it would work perfectly when I held the L2+R2 triggers down. When I got to the first battle, the characters kept on escaping from the battle screen (in the game, this is done by holding the aforementioned triggers down). The problem is that I didn't push any key. So it seems that for some reason the 2-triggers are stuck. I tried reconfiguring the gamepad, disconnecting everything (including the wireless receiver) and even installing ControllerMate demo, but nothing worked.

    I've heard that people have been able to use this controller in OS X so could this problem result in the fact that I'm using an XBOX controller with a PS-game. Should I just buy a 3rd party wired PS controller (Deal Extreme's got some cheap ones) to ensure compatibility? Or could there be a way to get the triggers unstuck?
     
  2. Tigerman82 thread starter macrumors 6502

    Joined:
    Jul 27, 2010
    #2
    I managed to find the answer on my own although I had to do some digging. Apparently I'm not the only one with this problem. I read a lot of thread from a lot of forums and found at least two posts where the answer was remapping the keys via keyboard (even though you are using a gamepad). One person had done this with Gamepad Companion but I'm glad I wasn't desperate enough to buy it from the App Store. I simple wen to PCSX-E Preferences and reconfigured the keyboard keys to the triggers (and to X). I had originally configured the X key to 'up' and the triggers to four different numpad keys. I reconfigured these to something other than numbers or arrows. And it worked!

    The X360 Wireless controller is now functioning perfectly. :apple:
     

Share This Page