Problem with Plex when playing movies while UMBP connected to TV...

Discussion in 'MacBook Pro' started by 1creator, Nov 18, 2009.

  1. 1creator macrumors member

    Joined:
    Oct 19, 2009
    #1
    So I just received the monoprice male mini-display + male usb audio to female hdmi... when I connected it to my tv it worked great. I changed output for audio to usb and safari and vlc worked great(i.e. hd youtube clips play without hiccup, 1080p movies work, 720p tv shows work)

    The only problem I had is when I open plex my sound suddenly goes from coming out of the TV to coming out of the built MBP speakers. What confused me is that sound effects ( when I raise or lower the volume using the shortcuts ) come out of of the tv speakers but the movie sounds come out of the MBP. I tried to look at settings in plex but I couldn't figure it out. Anyone know how to fix this??

    Help is greatly appreciated. I only mind because there are a couple of movies that don't work on vlc but work on plex.
     
  2. 1creator thread starter macrumors member

    Joined:
    Oct 19, 2009
    #2
    Does anyone else use this connection?

    Anyone have trouble getting plex to work through speakers that were plugged with a usb cable??
     
  3. King Mook Mook macrumors 6502

    #3
    Hi,
    Plex is in my opinion a UI nightmare. I use Aeon (http://www.aeonproject.com/) as my skin as it makes it much better.
    But anyway in normal Plex to change the sound output go to Preferences -> System -> Audio -> Audio Output Device and then change it to the output you want (it'll probably be something like USB Sound Output).
    Hope this helps,
    King Mook Mook

    P.S. Also to change the volume, change the normal sound output (in preferences) to the USB and then you can raise and lower the sound output volume normally.
     

Share This Page