Problem with preview and Snow Leopard

Discussion in 'macOS' started by soundbase, Mar 11, 2010.

  1. soundbase macrumors newbie

    Joined:
    May 17, 2009
    #1
    I am having problems with Preview and Snow Leopard.

    I can use Quick View to view jpeg files, but when I open them with preview. It does not display the correct image. It just displays a gray block.

    The only way to resolves this is to delete the preview prefernce files, and then it works. But after a couple of restarts it goes back to not displaying the correct image.

    Has anyone else had this problem, and how have they resolved it?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Have you tried repairing permissions yet?

    Are those .jpg files regular .jpg files or do they come from a special place and might use some "special" code? Some kind of camera or USB device or ... ?
     
  3. soundbase thread starter macrumors newbie

    Joined:
    May 17, 2009
    #3
    Problem with preview and Snow Leopard

    I am still having a problem with Preview and Snow Leopard.

    It is with any jpeg or image files, so it can't be a coding error.

    I have done the following, and still no luck:

    Repaired disk permissions
    deleted Preview preference files
    Deleted Preview, and installed again from System Discs using Pacifist
    Setup another use, and tested from new user, with same problem

    Any other ideas?

    When I setup the Macbook, it was a migration from an older Macbook. So I am worried something was pulled across that is giving the problem.

    I have done many migrations from other Mac's with 10.4 and 10.5 to 10.6 with no problem, so it must be something else.

    Any help will be much appreciated.
     
  4. Branton Wild macrumors newbie

    Joined:
    Oct 19, 2010
    #4
    Preview 4.0 installed snow leopard but says not compatable

    Hello, can anyone help me? I have snow leopard and preview will not work, it say you have preview 4.0, you can't use this version with mac os x.
    I have tried to update, re-install and use pacifist to install but nothing works, can anyone put me out of my misery, thanks :)
     
  5. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #5
    You should be using Preview version 5 on Snow Leopard. Version 4 undoubtedly isn't compatible.
     

Share This Page