Problem with Printer Networking - Any Ideas?

Discussion in 'Mac Basics and Help' started by hogmog, Oct 16, 2007.

  1. hogmog macrumors member

    Joined:
    Oct 30, 2006
    Location:
    Thames Valley, UK
    #1
    I have a Laserjet IIIP with a Netgear parallel port print server (PS101) connected to my home network with a fixed IP address. A Windows machine connected to the network has absolutely no problem printing to it. My Powerbook is a different proposition and I am stumped as to why - especially as I got it to work once. If I go to print, from Word for example, can choose the LJ (the print driver, Cups (?) installed when first got it to work) and the LJ dialogue box is launched. I then get the message in the dialogue saying "Network host 'xxx.xxx.x.xx' is busy: will retry in 30 seconds..." It then just sits there until I cancel the print job. I have checked:

    1) Using Safari to look at the status of the PS101 shows that it is far from busy - being reported as 'idle'.
    2) On the PB, pinging the IP address gets 10 responses so no loss of packets.
    3) On PB have checked firewall settings and they seem OK

    Any thoughts on what might be wrong and how it could be resolved?

    Connected, but a side issue, does anyone know of a standalone USB print server that works with the Mac? Have tried Netgear's one but does not work at all with Mac.

    Thanks
     
  2. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    I get this from time to time with my Laserjet 6L on a Dlink DP300U, (which has parallel and USB connectors to address your last question). I never get a problem on my Powerbook or Mac Mini, but my G5 iMac sometimes does the same as you're getting. The way I get it working again is to reset the printing system. If you follow the link, there's a link to some troubleshooting steps to try before you go for the reset.
     
  3. hogmog thread starter macrumors member

    Joined:
    Oct 30, 2006
    Location:
    Thames Valley, UK
    #3
    Thanks Blodwyn for the ideas and links. Have now had a chance to have a go unfortunately have met with no success. Even after doing the reset still get the same message. Have also updated Gimp (Gutenprint) to latest version so printer driver current but still no joy. Any more ideas anybody?
     
  4. anlund macrumors newbie

    Joined:
    Nov 6, 2007
    #4
    Same problem here

    I have exactly the same problem. I use a Netgear PS110 with a HP LaserJet 1015 connected to my LAN. It works fine from all the Windows machines and it used to work fine in Tiger. But now it is impossible to get it to work. If I try Appletalk, the printer outputs gibberish. If I use JetDirect, IPP or any of the other options, I get the "network host busy" error message.
    OS X - it does NOT work right out of the box anymore!:mad:
     
  5. spartian macrumors newbie

    Joined:
    Nov 14, 2007
    Location:
    pdx
    #5
    Thanks> I just bought the TRENDnet TE100-P1P> USE IPP LPD P1 setup

    Blodwyn, All,

    Thanks for the reminder about reseting the print system and related Apple help information. I usually use google which brought me to this thread, so it's good for myself to get that reminder.

    We have an old HP Laserjet 5mp which still runs great to this day, but unfortunately it has no USB port. Not wanting to give it up when my wife switched to a PowerBook (Tiger C2D) w/ Parallels (Vista) we initially tried an old AppleTalk to Ethernet bridge but had nothing but problems.

    I just bought the TRENDnet TE100-P1P and it connected the first time via bonjour on one of my Leopard computers, but the other computers one Tiger and one Leopard had problems connecting via bonjour. From the TRENDnet manual and troubleshooting info I managed to get Tiger to work via trial and error. On Tiger the final setup I came up with with the IPP-LPD (manual) setup using the regular HP Laserjet 5mp driver, but then both the Leopard clients still had these two basic errors even with the same LPD setup: Not authorized, Busy. I don't think that bonjour has worked since that initial first try.

    Via your tip, reseting the Leopard printing system and then re-adding the printer (in Leopard clients) via IPP while setting up the LPD setup manually (same as Tiger) with the Laserjet's IP address, which is fixed on my network, seems to have done the trick. The port id is part of the online setup for the TE100-P1P and is case sensitive according to the manual. I always included it and didn't try to see if it was part of the default setup for Leopard. In looking at the setup info, via the printer que, it lists the url of the printer as: 'lpd://192.168.1.3/P1'

    This setup allows both Tiger and Vista to share the same Laserjet printer on the MacBook via the network. Now that I've reset the printing system on the other Leopards, it all appears to be working. (knock on wood)

    Notes: For Vista I had to manually create a new port that connect via the network ip address and used LPR (not LPD) via the same P1 port. I'm not sure how you would do all this with a DHCP setup aside from reserving an address via the print server's mac id. Sorry if this is confusing, there's quite a few things going on and I wanted to be as specific as needed. I've done a bit of rewriting so hopefully it is clear.

    It seems this whole printing issue really has turned into a saga for many with no simple solution. My guess is that a truly networked printer wouldn't really have these problems because it would handle the queue and print driver itself rather than via the OS. FWIW, the 5mp was designed for both Mac and PC, and is a postscript printer as well. My experience is that spending a bit more time and slightly more money to find the product that mentions Mac compatibility, and does it's own processing is well worth the effort. Hopefully with the rise of the Macinitosh newer devices will get better as they will be designed for multiple platforms from the start.
     

Share This Page