Problem with Reinstalling Mac OS on Samsung SSD 850 Pro in Recovery Mode.

Discussion in 'MacBook Pro' started by LindskogLindskog, Sep 25, 2016.

  1. LindskogLindskog macrumors newbie

    Joined:
    Sep 25, 2016
    #1
    Hi,

    I'm having major issues with installing Mac OS on my newly purchased Samsung SSD 850 Pro through the Internet Recovery function on my Model 2012 13' Macbook Pro.

    I decided to buy a new internal SSD for my Macbook as the internal HDD was failing (giving me the folder with the question mark). I tried repairing, erasing and reinstalling the OS on the HDD but none of it worked. I ran into a number of problems after installing the SSD into my Macbook.

    At first, I couldn't use disk utility to erase and partition the SSD to the Mac OS Extended (Journaled) format as it would get stuck at the "partitioning" step in disk utility. I thought maybe something was wrong with disk utility so I plugged the SSD into my stationary PC at home and partitioned the SSD to the HFS format compatible with Mac. This was successful! I hoped that since the SSD was now in the correct format that installing the Mac OS in Internet Recovery would now work. However, when I installed the SSD into my Macbook Pro, it would find the SSD in disk utility (correctly formatted) but when I chose to install mac OS, it was not listed. I could not choose the SSD as the startup disk either. As far as I can tell, the MacBook was not able to mount the disk image under my SSD.

    The next step I did was to try and use the "First Aid" tab in disk utility on my partitioned SSD to try and "repair disk". Disk utility then gives me the following messages:

    Checking file system
    Volume repair complete
    Updating boot support partitions for the volume as required
    *red* Error: Disk utility can't repair this disk...disk, and restore your backed up files.*red*

    I am going crazy here because it feels like I've tried everything! I've heard a few people on forums talk about a damaged HDD cable but it feels like if this cable was damaged, disk utility would not detect my SSD at all, which it does.

    Any help with this would be highly highly appreciated because I just don't know what else to do!

    Thanks in advance.
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    A damaged cable is a good possibility. Do you have an external USB case you can put the SSD in? If so, if you can format it while connected by USB. If you can, then the SATA cable is almost certainly the problem.

    By the way, when you format it, makes sure the partition map shows as GUID and not MBR.
     
  3. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #3
    The drive working on your other machine rules it out as the issue and strongly points to the SATA cable as the culprit. It's quite common for failing SATA cables in these machines to work only partly, which is what you're seeing.

    Unless you definitely know your old disk is damaged or faulty, it's also quite likely that the bad cable was the cause of the issues you had before the drive change.
     
  4. LindskogLindskog thread starter macrumors newbie

    Joined:
    Sep 25, 2016
    #4
    Thanks for the quick replies JohnDS and JTToft!

    I was getting more and more sure about the faulty SATA cable but I found it strange that a cable could work "partially" haha. I thought that either a cable worked completely or that it didn't work at all. Interesting!

    I'm going to order the SATA cable and switch it out. Hopefully it will solve the issue. Fingers crossed!
     

Share This Page