Problem with Safari - Not updated???

Discussion in 'macOS' started by Skydiver32, Mar 24, 2010.

  1. Skydiver32 macrumors member

    Joined:
    May 15, 2009
    #1
    I've had this problem for a while, I've taken it to the Genius bar, but still no love.
    The problem: Safari pretty much works fine, except for a couple of websites, like Apple's One-to-One page and Netflix.

    When I attempt to sign in on 1-to-1, an error message tells me to update Safari 3.0 and install it. The same happens with netflix - instant watch.
    My Mac is fully update with Snow Leopard and the latest Safari (v 4.0.5). To make it even more weird, I get the same message when using FireFox.

    I've been told it was due to Parallels but I have uninstalled it, still no worky.

    Any suggestions

    See the error message below
     

    Attached Files:

  2. Skydiver32 thread starter macrumors member

    Joined:
    May 15, 2009
  3. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #3
    Safari > Reset Safari...

    don't check passwords...
     

Share This Page