Problem with Samsung 830 and cMBP Mid '12

Discussion in 'MacBook Pro' started by sevendave, Feb 12, 2014.

  1. sevendave macrumors newbie

    Joined:
    Jan 11, 2014
    #1
    Recently been having some trouble with my Samsung 830 SSD (256GB). Had a bit of trouble with it involving the SSD before xmas, took it in to my local Apple store and they said it was a damaged SATA cable and replaced it and I've had no trouble since. I installed the SSD in my MacBook Pro (13" mid 2012) when I got the MacBook, along with 8GB of Crucial memory.

    Yesterday I was on Safari on YouTube when I got the spinning wheel of death, tried Cmd-Alt-Esc and it wouldn't respond so I turned it off by holding the power button down. I went to restart my MacBook and it chimed and stayed on the white screen for about 20 seconds before flashing the question mark folder icon. So I rebooted into recovery, went into Disk Utility and my SSD wasn't showing up at all. Rebooted into the hardware test, did a quick test and it came back showing no errors. Reset the NVRAM, still wasn't showing in Disk Utility in recovery.

    Replaced the 8GB of Crucial RAM with the 4GB of RAM that the MacBook came with just in case. Took the SSD out of my MacBook and hooked it up to my PC, and installed the Samsung Magician software. The PC had no trouble finding the SSD and the Magician software said that the SSD was healthy, so I downloaded Clonezilla, made a live USB and rebooted into that, tried to make a clone of the drive onto an old spare hard drive but it complained of file system errors so I told it to do it again but automatically repair any errors, cloned it fine that time.

    I put the hard drive into my MacBook and it worked first time. I then made a Time Machine backup whilst I could. Took the hard drive out and connected it to my PC, along with my SSD and cloned the hard drive back onto the SSD. Clonezilla showed a few ATA errors, and some buffer errors on the hard drive but it eventually completed, put the SSD back into my macbook and it still didn't show up in Disk Utility in recovery mode. The ATA errors may have been from my PC, which is pretty close to dying.

    Took the SSD out and put it back in my PC, secure erased it with the Samsung Magician software and then formatted it with windows. Put it back in the MacBook and it still didn't show up.

    I then downloaded gparted, made a live USB and booted into that on the MacBook. The SSD showed up in that so I deleted the partition table and added a single HFS+ partition. Tried booting to recovery and the SSD didn't show in Disk Utility. Went back to gparted and tried formatting it to FAT32, still didn't show in Disk Utility.

    I put the SSD in an external USB 3 case and put my old hard drive in the MacBook. Booted, connected the SSD over USB and went into Disk Utility and it was there, so I repartitioned with a GUID table and made a HFS+ partition. Tried copying something to the partition and it copied fine. Swapped out the hard drive and the SSD, booted into recovery and again, SSD wasn't showing up in Disk Utility.

    I've tried everything I can think of, but it seems that the SSD refuses to work with OS X on my MacBook. Works fine with Windows 7 on my PC, works fine with gparted on my MacBook but doesn't show up when connected to the internal SATA port on my MacBook Pro when in OS X recovery.

    I don't think this is a problem with my MacBook so I don't think the Apple geniuses will be able to help me at all, although I may be wrong. The next thing I can think of doing is RMAing the SSD, but the fact that it works in my PC makes me think that I won't get very far with that.

    Can anybody think of anything else I could try before RMAing the SSD? Sorry for the wall of text, and thanks.
     
  2. sevendave thread starter macrumors newbie

    Joined:
    Jan 11, 2014
    #2
    Right, so my MacBook just froze, exactly the same way it did two days ago, force rebooted it and was met with a grey/white screen, exactly the same as two days ago. Booted into recovery and Disk Utility showed no hard drives connected to the system, exactly the same as two days ago. So it seems I have a MacBook that hoses disk drives. Willing to bet that the drive would work fine in my PC, but I've booked a Genius appointment for tomorrow and I'm bringing the SSD along with it; had the back of this machine off too many times for me to want to take it off again, it's Apple's problem now.
     
  3. dylin macrumors 6502a

    dylin

    Joined:
    Jun 10, 2010
    Location:
    California
    #3
    They said that it was a problem with the SATA cable and they replaced it? maybe the gave you an other bad cable and thats why it doesn't show up in disk utility.

    Or what if they never even fixed it at all :confused:
     
  4. sevendave thread starter macrumors newbie

    Joined:
    Jan 11, 2014
    #4
    Yeah, they said the SATA cable was broken and replaced it, invoiced me for it but I have the education Applecare so the repair was free. I think they fixed it, it had been working fine since about October I think
     

Share This Page