Problem with SATA cable? or logic board?

Discussion in 'MacBook Pro' started by kitkatpatel, Mar 19, 2013.

  1. kitkatpatel, Mar 19, 2013
    Last edited: Mar 23, 2013

    kitkatpatel macrumors newbie

    Joined:
    Mar 19, 2013
    #1
    I recently did a software update which required a restart, however, after installing the update my macbook pro (15 inch early 2011 model) would not boot onto the internal hard drive. Everytime I tried booting it gave me a circle with a slash sign. The recovery drive boots fine but if I try to reboot Mountain Lion on my internal it will give me the same circle with a slash sign. I tried zapping the PRAM, booting into safe mode and booting into single user mode with no success.
    Next I booted off an Mac OS X Mountain Lion Installation thumb drive. But now it would not mount my internal hard drive on disk utility or the install mac os X option. My internal hard drive wont show up at all even after zapping the PRAM again.
    After that, I took the internal had drive out and tried booting off of it as an external and it DOES boot off of it just fine.
    I ran an Apple Hardware Test and it showed no problems.
    Since the recovery drive on the internal hard drive (connected via the native SATA connection) did work and the partition on which the OS is doesnt work I decided to do a clean install. Again the same problem, recovery drive boots fine but the partition with the newly installed Mountain Lion wont boot.
    I am thinking it's a hardware problem possibly the native SATA connector cable or the logic board. Anyway I can pinpoint the exact problem?
    The reason I am asking is I can buy a new SATA connector cable for $50 online instead of taking it to apple and them charging me a crap load for it.


    PS: sorry about the extra long story narration, my first post ever on a forum. Thankyou for any advice/feedback on my issue.
     
  2. kitkatpatel thread starter macrumors newbie

    Joined:
    Mar 19, 2013
    #2
    Solved the issue

    So turns out it was a simple firmware issue. The firmware on my Intel X-25M SSD was outdated. I updated the firmware as directed by their website and waahlaa everything works like normal :):D
     

Share This Page