Problem with Sims 2 !!!

Discussion in 'Mac and PC Games' started by Hiper510, Jan 13, 2008.

  1. Hiper510 macrumors newbie

    Joined:
    Jan 13, 2008
    #1
    I just recently bought the sims 2 game. I have a brand new imac that's not even a month old yet

    2.0GHz Intel Core 2 Processor
    4MB shared L2 cache
    1 GB of 667 MHz DDR2 SDRAM
    250GB Serial ATA hard drive

    not that i understand what half of that is, but i believe it meets requirements... although when i load the game i says i need a 500 MHz processor or higher, and therefore the game wont work properly, which i thought i had, but it says i don't have.

    then when i go to play the game when i'm in neighborhood view and in the house view the screen seems to scramble and isn't displaying things right.

    I installed the patch, and i tried lowered the display options on the game, when that didn't work, i raised them, still didn't work. i think i've tried everything to solve the processor and display problems... HELP!
     
  2. lucky3killer macrumors regular

    Joined:
    Oct 24, 2007
    #2
    That's odd, The Sims 2 is working so great on my Intel iMac, black Alu with HD 2400 XT and installed all expansion packs too.

    You need get Bon Voyage (expansion pack) and install the patch on applied original (The Sims 2) and expansion packs if you owned but do not install combo patch if you don't own all expansion packs.
    http://support.aspyr.com/index.php?x=&mod_id=2

    After that, you need hit and hold on command (or apple icon) as this game start then uncheck render graphic (just disable it) before run the game because it cause an graphic issue on iMac with annoying blue flashing.
     
  3. Hiper510 thread starter macrumors newbie

    Joined:
    Jan 13, 2008
    #3
    After i get Bon Voyage the glitch will go away?.. and then i can get all the other expansion packs without it going back to the glitch?
     
  4. macman232 macrumors newbie

    Joined:
    Jan 19, 2008
    #4
    I have this exact model imac, I'm assuming you have mac os 10.5 leopard. you DO NOT have to buy any expansion packs, just hold command when starting the game and uncheck "optimized graphics" as stated above.
     

Share This Page