Problem with Siri Languages showing up as ((null))

Discussion in 'iOS 7' started by TechGuy18, Sep 17, 2013.

  1. TechGuy18, Sep 17, 2013
    Last edited: Sep 17, 2013

    TechGuy18 macrumors member

    Oct 8, 2012
  2. TommyA6 macrumors 65816

    May 15, 2013
    1. Hard reset
    2. If that doesn't work, restore (best to set up as new)
  3. TechGuy18 thread starter macrumors member

    Oct 8, 2012
    I tried both of these things including a dfu restore and nothing has worked, I just don't know how to possibly fix this.
  4. Karasmyr macrumors newbie

    Sep 18, 2013
    I am having the exact same problem with my iPhone 4S.

    I have been unable to fix it no matter what I have tried, including the suggestions above. Please help!!
  5. Karasmyr, Sep 18, 2013
    Last edited: Sep 18, 2013

    Karasmyr macrumors newbie

    Sep 18, 2013
    I figured out how to fix it. Go to "International" under settings and change your language to something else, like English (Australia), Once it changes, the ((null)) language settings under Siri go away and are replaced with the correct options. Then simply change back to your original language under the "International" settings and set Siri to whatever language you desire.
  6. Joshposh2012 macrumors newbie

    Jan 8, 2014
  7. Pieter444 macrumors newbie

    May 17, 2014
    Siri languages appear as null

    Did did as suggested--changed the language under INTERNATIONAL in GENERAL in settings.

    It did work; Siri now has languages listed, but now when I text the words are in French, not English, though I have changed it many times and turned of the phone, an iPhone 4s.

    I can't be texting in French. Any ideas?
  8. grockk macrumors 6502


    Mar 16, 2006
    On iPad the settings are under General->Language and Region->iPad language. Switched to British and back to American and all is well. Thanks.

Share This Page