Problem with sleeping

Discussion in 'macOS' started by VladM, May 25, 2009.

  1. VladM macrumors regular

    Joined:
    Oct 23, 2008
    #1
    Sometimes, when I close the lid on my macbook, and reopen a few hours later, the following happens:

    While the macbook (unibody) is closed, the breathing light (the little white on the front) is lit solid (i.e. not coming on and off as during normal sleep). When I open the lid, the light goes out, and the macbook is completely unresponsive. The only way to get it up and running again is to hold the power button down until it shuts down, then restart.

    Why does this happen?
     
  2. DPB17 macrumors 6502

    Joined:
    Jul 29, 2008
    Location:
    Ireland, unfortunately.
    #2
    The exact same thing happened to me when I installed some dodgy RAM in my Unibody Macbook and I tried everything like resetting PRAM, hardware test, swapping RAM to different bays and nothing worked. Eventually I just bought a different set of RAM modules and everything worked perfectly. If you have installed new RAM try resetting PRAM and do an SMC reset and also an Apple hardware test to see if there are any issues. This is all presuming that you installed new RAM, if you didn't I guess just bring to an Apple store!:D
     
  3. VladM thread starter macrumors regular

    Joined:
    Oct 23, 2008
    #3
    Hmmm I did install 2x2GB of RAM, but this was about 2 months ago and I only started noticing the problem recently. As a matter of fact, I only started noticing it when I installed that monitoring widget (the one that monitors temp, fan, ram, hdd, etc - the name escapes me now), which I have since uninstalled. Funnily enough I had similar problems with my white macbook also after I installed that widget.

    Update: I think it has something to do with my BT mightymouse. It seems that when the mouse is clicked while the machine is sleeping (can happen very easily since I routinely forget to switch off the MM and just chuck it in the bag), the MB sort of wakes up and goes into this mode. Hmmm, I will investigate this a bit more.
     
  4. DarkJaye macrumors member

    Joined:
    May 11, 2009
    #4
    Make sure you have the Allow bluetooth devices to wake this computer option unchecked! Pic below.
     

    Attached Files:

  5. VladM thread starter macrumors regular

    Joined:
    Oct 23, 2008
    #5
    Yep, this was the culprit. Thanks. I thought it was unchecked but when I looked it wasn't.
     

Share This Page