Problem with Software Update

Discussion in 'MacBook Pro' started by mohemoto, Jan 22, 2011.

  1. mohemoto macrumors newbie

    Joined:
    Jan 22, 2011
    #1
    Hey guys,

    I'm currently running Mac OS X 10.6.3, and I'm having issues with the software updater. Every time I try to run it, it shows me the new updates, and I click "install". It installs them from the desktop, and then tells me to restart the computer, which I do. Upon restarting, it goes through another process of installation, but once the blue loading bar gets a third of the way to completion, I get a very vague error message. All the message says is "Error, the software update could not be completed". I then press "ok" and get redirected to another message which says "None of the selected updates could be installed. The update could not be expanded and may have been corrupted during downloading".

    I have contacted Apple Support, but they have been quite useless in resolving this issue. I have so far tried the following things:

    1) Reset the P-RAM
    2) Verify and Repair Permissions
    3) Insert the Mac-OS X Install Disk, and repair the disk using disk utilities
    4) Manually downloaded the combo update from the Apple website

    None of these have changed anything. Does anyone have any other suggestions? This is getting extremely frustrating. Thanks for any help!
     
  2. Hitman33 macrumors newbie

    Joined:
    Jan 25, 2011
    #2
    I am having the exact same problem. I have an 8 month old MacBook pro....

    this is driving me nuts. I haven't even tried the things you have.

    Any help here would be greatly appreciated since I just registered because I found this thread on Google!
     
  3. mohemoto thread starter macrumors newbie

    Joined:
    Jan 22, 2011
    #3
    That's ironic, mine is 8 months old too...I really want to solve this problem, I'm sick of being stuck with outdated software!
     
  4. NZed macrumors 65816

    NZed

    Joined:
    Jan 24, 2011
    Location:
    Canada, Eh?
    #4
    try downloading the update from Apple.co, the 10.6.6 update.
    There are 2 a normal update which is about 200+mb, and the Combo update, which is about 1.06GB. i would recommend the Combo Update
     
  5. mohemoto thread starter macrumors newbie

    Joined:
    Jan 22, 2011
    #5
    I have already tried that (see 4), and the same error occurs..
     

Share This Page