Problem with Spotlight search criteria - ITS MISSING!

Discussion in 'macOS' started by m021478, Mar 8, 2008.

  1. m021478 macrumors 6502

    Joined:
    Nov 23, 2007
    #1
    Here is a screenshot of the typical spotlight window on a 10.5.2 machine (Intel mac pro):

    [​IMG]

    Here is a screenshot of the same window after I click the '+' sign to add an additional search criteria value:

    [​IMG]

    In the second screenshot, that extra blank space at the bottom is where is supposed to say Name: or Kind: etc...but its just not there and I have no idea why??

    I have tried creating a new user account on my machine to see if the same issue occurred their as well, and sure enough, it does not.

    I have tried all sorts of maintenance and repair tactics to resolve the issue (such as repairing permissions, running DIsk Warrior, Cocktail, Onyx, Leopard Cache Cleaner, etc...) but nothing seems to resolve the issue??

    Anyone have any thoughts as to what the issue might be, and how I can go about fixing it?


    FYI - In case any does know of any third-party apps that might cause this issue, below are a few screenshots showing some of the apps, system preferences, and processes running on my machine:

    Applications Folder:
    http://img116.imageshack.us/img116/8...sfolderuj1.png

    System Preferences:
    http://img155.imageshack.us/img155/9493/sysprefsiq9.png

    My Processes:
    http://img155.imageshack.us/img155/1...ocesseseq3.png
     
  2. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    It could be the app "A Better Finder"

    What's it do ?
     
  3. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #3
    Its a batch file renaming program...

    Is your suggestion said with any reasoning (meaning did you hear this program was known to do such a thing to the Finder's spotlight capabilities), or are you guessing?
     
  4. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #4
    I checked the console for error messages upon expanding the finder window search criteria menu, and it resulted in the following message being generated...

    Sender[PID]:
    Finder [242]

    Message:
    HIToolbox: ignoring exception 'Delete returned nil for call to ruleEditor:0x1c1247d0 displayValueForCriterion:0x51c760 inRow:0' that raised inside Carbon event dispatch

    Anyone have any idea what this means?
     
  5. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #5
    OK, so this is a weird one...I found this link in searching the net for a solution to my problem, in which some other guy who was having the exact same issue managed to resolve his problem by...get this...trashing his com.apple.finder.plist file, then instead of just restarting (which didn't work for him, or for me to resolve the issue) instead, immediately after trashing the com.apple.finder.plist file, holding down the power button for 5 seconds to force-shutdown

    Low and behold, I tried it and it worked!! The issue is not an issue anymore!
     

Share This Page