Problem with Steam - Won't launch

Discussion in 'Mac Apps and Mac App Store' started by Zedsdead185, Jun 19, 2011.

  1. Zedsdead185 macrumors 6502

    Joined:
    Sep 14, 2006
    Location:
    UK
    #1
    Hi all,

    I'm currently having problems with my steam app and was wondering if anyone could help me out?

    The problem is simply that it refuses to launch. Everytime I try to launch it I get a message saying that it needs to update and that it can't connect to the internet (screenshot included). The problem is however that my internet seems to be working perfectly, and have also tried on 2 other networks. I can't seem to find any way around it.

    I have already tried to re-download and re-install steam from their website but the exact same message seems to be popping up. I would rather not have to use my app cleaning program to install every shred of steam on my mac as I have a large amount of games on it and re-downloading them would be a major pain.

    And just for further info I am running an early 2010 15" unibody macbook pro with the latest updates from snow leopard.

    Any help at all will be appreciated, thanks guys
     

    Attached Files:

  2. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #2
    Have you tried rebooting your mac? That's a good first step with networking issues.

    If not, go to your Steam Folder (/Users/<username>/Library/Application Support/Steam) and delete the ClientRegistry file - or move it to another relocation and reopen Steam and log on again. That worked for me when I had this problem.

    If you want to delete everything and reload Steam, I'd first move the Steam Apps folder to another location so you don't have to re-download all you games.
     

Share This Page