Problem with terminal

Discussion in 'macOS' started by alon121212, Jul 27, 2011.

  1. alon121212 macrumors newbie

    Joined:
    Jul 27, 2011
    #1
    Hi everyone,

    While i was trying to figure out how to get my external HD to work, I ran

    through a guide that i thought was related to my problem...

    Problem is when i realized it wasn't what i needed it was too late. I did this:

    "1) Launch /Applications/Utilities/Terminal and do:

    sudo chmod o+w /Library/Preferences

    defaults write /Library/Preferences/com.apple.AppleShareClient afp_host_prefs_version -int 1

    Now restart your computer".

    Now my computer won't connect to the sabnzbd server...

    Could anyone please tell me how i can reverse this?

    Thanks alot!
     
  2. psxguru macrumors 6502a

    Joined:
    May 19, 2006
    #2
    Easiest way is to open finder, browse to /Library/Preferences

    then doubleclick on com.apple.AppleShareClient.plist

    this should open with the property list editor.

    find the afp_host_prefs_version key and change the value from 1.
    It's set to 10 on my mac, not sure if this is the default but no harm in trying!
     
  3. tag macrumors 6502a

    tag

    Joined:
    Apr 29, 2005
    #3
    I'm guessing you have Lion?

    Can I assume that you tried what you did based on this Apple Lion Server article or some blogs/forums variation of it?

    From reading the article I linked to it seems you didn't fully finished the process (assuming this is what you were trying to do).

    What I do know for sure is the commands you entered, once you restarted your computer, left a process running that was waiting for you to modify/create a User Authentication Method to be saved in your Preferences.

    It does say at the end how to re-disable whatever you had enabled, but I'm not sure what you would re-disable since you didn't really enable anything since you didn't complete the commands.

    Again, this is a good bit of speculation on my part and I can't really test this as I'm on Snow Leopard myself, but I would close up your Preferences again via the last step and see if that corrects it...

    sudo chmod o-w /Library/Preferences

    Then restart and see if that fixes it.
     
  4. alon121212 thread starter macrumors newbie

    Joined:
    Jul 27, 2011
    #4
  5. alon121212 thread starter macrumors newbie

    Joined:
    Jul 27, 2011
    #5
    well eventually i tried repairing the hard disk using disk utility and it worked...

    So thanks a lot for your help but this thread can now be closed...

    :):):)
     

Share This Page