Problem with Text Message Forwarding

Discussion in 'iPhone' started by mikelan6, Feb 20, 2017.

  1. mikelan6 macrumors newbie

    Joined:
    Sep 20, 2012
    #1
    I have an iPhone 7 and have been using it for a few months now. I also have an iPad and an iMac.

    For some reason, I am no longer able to "Forward Text Messages" from my iPhone to the other devices like I used to.

    The settings > Messages > Text Messaging Forward is not in my settings any more. iMessages works fine, but SMSs do not.

    Does anyone have any ideas?
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    Make sure you are signed into all devices (iCloud) with the same Apple ID and on the same wifi.
    Make sure you are signed into iMessages and FaceTime with the same Apple ID etc.
     
  3. mikelan6 thread starter macrumors newbie

    Joined:
    Sep 20, 2012
    #3
    iMessage is not the problem. It's texts (SMS) that do not connect to the iPad any more.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    BasicGreatGuy is trying to help. You ought to follow the advice. It's good. He knows more than you do.
     
  5. Peter K. macrumors 6502a

    Peter K.

    Joined:
    Nov 6, 2012
    Location:
    SoCal
    #5
    Who is your carrier?
     
  6. mikelan6 thread starter macrumors newbie

    Joined:
    Sep 20, 2012
    #6
    I use Net10. Do you think the carrier is blocking that setting?
     
  7. Peter K. macrumors 6502a

    Peter K.

    Joined:
    Nov 6, 2012
    Location:
    SoCal
    #7
    I apologize, but I don't know what to say now. I was expecting you to say AT&T. I would have told you to call them to make sure that NumberSync was still provisioned properly on your account.

    I didn't know text message forwarding was even possible on MVNOs.
     
  8. mikelan6 thread starter macrumors newbie

    Joined:
    Sep 20, 2012
    #8
    Thank you everyone for the help. With the clue that @Peter K. gave me, I took out my Net10 SIM card and inserted my Three UK SIM card and the Text Forward feature was there! I returned the Net10 SIM and the Text Forward feature stayed.

    How? Why? I will never know.

    Thanks guys.
     
  9. Peter K. macrumors 6502a

    Peter K.

    Joined:
    Nov 6, 2012
    Location:
    SoCal
    #9
    Wow, neither do I know how or why, but I'm glad it worked out.
     
  10. a4gash macrumors newbie

    Joined:
    Sep 20, 2017
    Location:
    New York
    #10
    --- Post Merged, Sep 20, 2017 ---
    I had the same problem, and was on with apple for an hour. They were clueless. When I hung up I found this thread, but as I didn't have a different SIM, all i did was remove my AT&T SIM and then I put it back in again. The text forwarding option appeared! Problem solved. Thanks!
     

Share This Page