Problem with umlaut and accents in Safari 5.1

Discussion in 'Mac Apps and Mac App Store' started by swedefish, Aug 5, 2011.

  1. swedefish, Aug 5, 2011
    Last edited: Aug 6, 2011

    swedefish macrumors 6502

    Joined:
    Feb 12, 2008
    #1
    I use a U.S. keyboard and hence the U.S. keyboard set in OS 10.7. However, I often have to use umlauts (¨) and accents when I write. Since forever I am using the keyboard method for producing these, e.g. umlaut = alt+u followed by letter on which I desire the umlaut. However, randomly and seemingly for no apparent reason I get the following: I press alt+u and instead of creating a highlighted "¨" in my text field, Safari opens a new window where the highlighted "¨" shows up, however, it won't let me type in any letter and I am left unable to insert umlauts and accents using the method I've been using for years. I know this sounds very convoluted so please see the pic where I point out the odd window that Safari opens.

    Does anyone know why this happens and how, if possible, this window that pops up can be disabled?

    Many thanks!

    [​IMG]
     
  2. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #2
    Anyone? I can't seem to find any info on this anywhere but then again, I don't even know what that pop-up window is called so searching is a bit difficult. I'd like to think I'm not the only person experiencing this issue. :confused:
     
  3. tico125 macrumors newbie

    Joined:
    Aug 14, 2011
    #3
    I use a Spanish keyboard and I've been having the same issue ever since I upgraded to Safari 5.1

    I ran a clean installation of OS X Lion 2 weeks ago and I'm still having the same issue.

    What I do is close Safari and open it again and most of the time the issue is gone afterwards. However, I reported this issue to Apple from the feedback option in Safari, because this bug is kinda annoying :mad:

    D.G. :apple:
     
  4. MigueldelRio macrumors newbie

    Joined:
    Mar 14, 2009
    Location:
    Madrid, Spain
    #4
    Yep, same here. Seems they screwed up. And it's not only on Lion, my girlfriend has Snow Leopard and has the same issue, so it must be Safari-related. Hope someone finds the way out of this... Cheers!
     
  5. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #5
    Glad to know I am not the only one with this problem, but it is indeed a highly annoying bug. I've also reported the problem to Apple but I was unable to provide instructions for how to recreate the poblem as it seems to occur randomly.
     
  6. FluffyPop macrumors member

    Joined:
    Aug 20, 2011
    #6
    There is a new feature in Lion that makes typing special characters easier as long as you don't do it very often. If you press and hold a character it will display a list of special characters, just like in iOS. It's rather nifty :)
     
  7. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #7
    Yeah, I am aware of this new feature, but once the described bug occurs, the press and hold method for special characters stops working. Furthermore, as someone who has used a US keyboard for the past eight years, I have become used to creating the Swedish letters I need through keyboard commands and this habit is very hard to break. That said, I don't think I should have to change my habit--Apple should just fix this odd bug!
     
  8. Sir Lorad macrumors member

    Joined:
    Apr 22, 2010
    Location:
    Brazil
  9. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #9
    Does anyone know what this glitch is called or what might cause it? I want to write another error report to Apple, but I feel stupid calling it "the 'thingy' that randomly pops up". This is one of the most frustrating bugs I have come across in all my years as a Safari user. :mad:
     
  10. blipmusic, Sep 2, 2011
    Last edited: Sep 2, 2011

    blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #10
    Tried on 10.7.1 and it seems to work ok in Safari in my case.

    Do you have any other, non-Apple, input managers installed?

    My main keyboard setup is Swedish and in that envronment alt-u creates a standard umlaut u. The same shortcut creates a highlighted umlaut diacritic as expected in any of the US setups.

    The pop-up you get looks similar to the pop up for non-latin alphabets (well at least for Japanese, but I'd guess others as well) when there is no "inline input" support for certain languages - I don't know if that's a correct description this is just from experience.

    I use command+space for quickly switching between Swedish and Japanese, perhaps you can try the same until the bug gets sorted out? [EDIT: Ehm, maybe not a good idea since you probably have a US layout on your keyboard and switching between similar latin alphabets with different layouts might be a tad frustrating...at first, least.]
     
  11. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #11
    I've seen this in Adium (OS 10.6), intermittently after switching from Hiragana (Japanese) to Romaji. In my case it doesn't get stuck there but rather disappears after one character, ignoring what I typed. When I begin typing, I see the window flash up but I've typed the second character by the time I've noticed what's going on and the window disappears again.

    The end result is that I miss the first character of whatever I'm typing; "hello" comes out as "ello", etc.
     
  12. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #12
    Nope, I don't have any other input managers installes. Also, this error doesn't always happen. I can't seem to reproduce it on purpose. Rather, the bug will occur randomly according to no apparent pattern. I don't write in Swedish enough to want to get the inferior Swedish keyboard instead of the U.S. keyboard, which I consider significantly better for typing (love the U.S. return key).
     
  13. blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #13
    What? You didn't get the memo? Swedish (hardware) keyboards are superior! I kid, I kid, I'd simply want the hardware keyboard to reflect my mother tongue (Swedish, in my case). :)

    The only thing I can think of is that you might sometimes start typing prematurely (e.g. before a field has been properly selected, though you would surely have noticed by now), that's usually when I get that pop-up for Japanese.

    I believe that the diacritic is setup to "wait" for a character to transform (hence the highlight), e.g umlaut followed by 'a' creates 'ä'. This is the case for Japanese, where you won't get the corresponding Japanese kana (largely CV-syllables) until you "complete" the character. Writing 'r' yields only a latin 'r' but upon typing 'i' you get the corresponding Japanese kana for 'ri' as the output.

    I'm sure you're aware of all of the above I'm just curious whether the "completed" character appears in the correct text field or if the output stays in that pop-up field?

    (I probably couldn't help either way, just something you might want to add in a bug report.)
     
  14. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #14
    Swedish is my mother tongue as well, but I don't use it on a daily basis and for the rare occasions that I have to write something in Swedish I am now so used to the abovementioned method on my U.S. keyboard that I am actually a faster Swedish typist on the U.S. keyboad as opposed to the Swedish keyboard. :eek:

    As for typing prematurely, I don't think that is the case. The thing is that once this bug makes itself known, it will appear every single time I try to insert an accent or an umlaut. This is a problem because I am actually not able to produce the desired letter, ie the little window opens, but I am unable to actually add a letter to the umlaut, etc. So once the bug kicks in, I must restart Safari if I want to be able to work with diacritics. A mess.
     
  15. blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #15
    You've piqued my interest to try out a US keyboard whenever I get a chance (considering I have a lot of writing ahead of me). :D

    That really does sound like a bug. Make sure you let Apple know.

    Lycka till!
     
  16. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #16
    Tack :)

    Submitted the bug report (again) and I encourage everyone else who exoeriences this issue to do the same.

    The US keyboard is an acquired taste, but the long horizontal return key serves me better than the clunky enter key on Swedish keyboards, same goes for punctuation marks. Plus, laptops with the US keyboard are easier to sell after I am done with them--not much of a market for Swedish keyboards outside Sweden.
     
  17. dexterciyo, Sep 8, 2011
    Last edited: Sep 8, 2011

    dexterciyo macrumors newbie

    Joined:
    Sep 8, 2011
    #17
    I have had this problem too. And it is quite annoying.

    I think I have come to a solution, that is working for me so far. It is related to this new feature:

    Since I disabled this, for I find it nothing "nifty" at all, but clumsy, it seems my accents turn up as usual: Aquí lo estoy probando. Ich teste hier für euch.

    Just type this in Terminal:

    Code:
    defaults write -g ApplePressAndHoldEnabled -bool false
    Let me know if this works for you.

    Best regards.

    EDIT: It is still not working. :(
     
  18. ftonello macrumors newbie

    Joined:
    Nov 6, 2008
    #18
    Accents in portuguese

    Same with me here in Brazil. Anyone solve this problem?
     
  19. diegaulle macrumors newbie

    Joined:
    Oct 20, 2009
    #19
    I gave that Terminal command a try. Didn't work for me. Funny thing is, i still can alt+u alt+e anywhere else in Safari but in the search field.

    Firefox works fine.

    I have glims installed.

    Someone could fix it by changing the search engine from Google to Google Standard.

    I use ue, oe, ae instead of ü, ö, ä there and google digs it without bother. It might help you too while trying to type umlauts until Apple comes up with a fix.

    Saludos
     

Share This Page