Problem with Unibody Macbook after memory upgrade

Discussion in 'MacBook' started by galactic732, Jun 21, 2009.

  1. galactic732 macrumors member

    Joined:
    Jun 5, 2008
    #1
    So i recently upgraded my macbooks memory from 2GB to 4 GB using this 2x2GB kit from newegg.com

    http://www.newegg.com/Product/Product.aspx?Item=N82E16820226019

    after installing osx recognizes the 4 GB, I ran both the memory test on the install CDs and the memory test "Rember" and both tests passed.

    However, when I close the lid to put the macbook to sleep and open it up to wake it back up, the macbook WILL NOT wake up. I can hear the HD spinning but the only way to get my macbook up and working again is to do a hard reset.

    I switched out one of the 2 GB modules for a 1 GB module that came out and both 2 GB modules work with the 1 GB module.

    Also, both 2 GB modules work alone.

    Apple said that the "timings" could be off with the memory and won't help me bc its third party RAM, and insisted I spend 2.5x the price to get "apple branded RAM."

    Has anyone been able to find a fix to this issue?

    Thanks so much (it's been a very frustrating day)
     
  2. galactic732 thread starter macrumors member

    Joined:
    Jun 5, 2008
    #2
    help?

    could REALLY use some help on this topic....

    thanks in advance
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    Call newegg and tell them about it; they should replace the RAM.
     
  4. clyde2801 macrumors 601

    clyde2801

    Joined:
    Mar 6, 2008
    Location:
    In the land of no hills and red dirt.
  5. crzdmniac macrumors regular

    Joined:
    Aug 23, 2007
    #5
    You could also have a corrupt sleep file. The command in terminal is "sudo rm /private/var/vm/sleepimage". It will rebuilt after a reboot during the next time you put your machine to sleep.
     
  6. galactic732 thread starter macrumors member

    Joined:
    Jun 5, 2008
    #6
    none of these things worked...

    any other ideas?
     

Share This Page