Problem with Wi-Fi

Discussion in 'OS X Mavericks (10.9)' started by marcoxve, Dec 8, 2014.

  1. marcoxve, Dec 8, 2014
    Last edited: Dec 8, 2014

    marcoxve macrumors newbie

    Joined:
    Dec 8, 2014
    #1
    Hey I had a problem with Yosemite so I had to downgrade (wi-fi went off after 10 or so seconds of connecting to a network) to Mavericks, but now I don't have wi-fi at all-

    1) The interface does not appear listed under System Preferences -> Network.

    2) After I turn on the Interface name that should represent the wifi (en1) I can't turn on the Airport app via terminal with the command "sudo networksetup -setairportpower en1"; I still get the message: "You cannot set Wi-Fi power because all Airport network are disabled. If I use the option "-createnetworkservice AirPort en1" I get the error "Unable to access the System Configuration database."

    3) I already deleted everything in /Library/Preferences/SystemConfiguration/

    4) It is weird but when I click the "+" Icon on the network services am interface named "Thunderbolt 1" appears, if I try to make a new service out of this Interface after I click the "Create" button no service is created.

    5) If I run "sudo networksetup -listallhardwarereports" I get Ethernet, Firewire, Thunderbolt1(en1), Thunderbolt Bridge (bridge0)

    6) On the system information app if I go to Wi-Fi some info is displayed.

    I just don't really know what to do anymore
     
  2. ndunks macrumors newbie

    Joined:
    Dec 26, 2014
    #2
    try deleting thunderbolt bridge in the 'manage virtual interfaces' section, then in the network menu, disable thunderbolt completely, then restart computer. It should then create new wifi connection.



     
  3. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #3
    Your post is "above my head" -- I can tell, because you're using "developer-style" command-line commands.

    So, with humbleness, I'll make a suggestion:

    Go into System Preferences and into Users, and create a Brand New User.

    Log out, then log yourself back in as the New User you just created.

    See if you have WiFi.

    If you do, make the following mental note: "Okay, I have Wi-Fi when I create a new User."

    Now, log out, and then log back in as your old Original User (the "real you."), and then:

    Start up Console.

    With Console running, do that thingy you described (where you said "...if I try to make a new service out of this Interface after I click the "Create" button no service is created..."), and then look at Console to see if it is giving you any error messages.

    Also, while your in Console, read through all the System Messages that the system posted, because there might be some messages that say something like "tried to blah blah blah, but xyz was not initialized, etc."

    See where I'm going with all of this? (Good, because I don't hahah). Actually, I would piece together all the clues. If you have WiFi in the New User you created, maybe you can see what plist (preference) files are there that aren't there while you're logged in as the Original User, and vice versa. When you find differing/varying preference files, you can delete delete delete, and eventually your system will rebuild what it needs.

    No, this isn't the "expert" scientific approach. But, hey, I don't work at Apple LOL.

    But I know if I had the same problem on my computer, I could fix it using this methodology :p

    Please post back and let me know if any of my thoughts/ideas/suggestions were of any help.
     
  4. marcoxve thread starter macrumors newbie

    Joined:
    Dec 8, 2014
    #4
    Ndunks I did as you suggested, When the Mac was restarted it detected the thunderbolt bridge again but no Wi-Fi,
    Sharon the same thing happened when I created another user, no W-iFi for him :(.

    Thanks you both for your help anyways...
     

Share This Page