problem with wifi, again in lion

Discussion in 'Mac OS X Lion (10.7)' started by miladgh, Aug 2, 2011.

  1. miladgh macrumors newbie

    Aug 2, 2011
    I installed mac os x lion a couple of days ago. when I had snow leopard, I had a problem connecting to my wifi network. sometimes, when I turned on the computer, or waken it up from standby, it happened. it was like this:
    it didn't connect to the wifi network. it gave me an error when I was trying to select my network manually -> "connection timeout".
    sometimes, it didn't list ANY wifi networks at all! (so the problem is not with my router; which brand is Zyxel). I even tried changing the router's channel, resetting the wifi preferences (by deleting proper files on mac and many other solutions; but non was the answer)
    however when I did a fresh installation of snow leopard, this problem did not come back.
    a few days ago, i switched to lion. the same problem happened on day one, when I restarted my computer. (it was a fresh installation; I made a bootable dvd)
    today, it happened again. when I turned on the computer, it just showed me an empty window, saying: no network is available; although we have many wifi networks around the neighborhood. (that's why i know the problem is not my router)
    I recorded a part of the screen. here it is:
    i wanted to record again to have a better view. but when i turned wifi off and back on (after 30 seconds) it was solved. I'm guessing the problem might be with the number of apps at the login. (5 small apps). my theory is when the OS is booting, it gets busy doing other tasks that it can't perform tasks required to load the wifi stuff! but maybe not.

Share This Page