problem with wireless connection

Discussion in 'General Mac Discussion' started by Larrycleve, Feb 7, 2005.

  1. Larrycleve macrumors newbie

    Feb 7, 2005
    I have an ibook g4 connected wirelessly to a dlink router. Everything was working fine and without changing anything it can't connect to the internet. The wavy lines show a strong signal but the browser and e-mail app say server can't be found. I noticed that in the network section under airport and tcp/ip that the ip address was different from the router's. When renewed it said airport had its own contained ip address and might not be able to connect to the internet. When I tried manually putting in the router's address and rebooting, it said the router's ip address was already in use. Still no internet connection. I've used windows computers for 15 years, had my share of frustrations with them, but was always eventually able to straighten things out. This is my first apple computer, I got it because it's supposed to be easier to use than windows. It has been nothing but a continual pain in the neck and i'll never buy one again. Any ideas on how to get back on the internet?
  2. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    RTFM, would be my first suggestion.

    You can't set your mac's IP to be the same as the router. The router will have your external IP address as given by your modem. It then gives an IP to all the clients on your network, usually on a reserved local subnet such as 192.168.x.x

    So I would

    1. reset cable/dsl modem - usually accomplished by unplugging for more than 30 sec
    2. hard reset router - make sure to enable any special settings such as MAC (Media Access Control) settings or PPPoE
    3. reset your mac to use DHCP and clear any previous wireless settings, then reboot it.

    Wait for each step to finish before proceeding. If you have no idea what I just said - again....RTFM

    PS. Bashing your mac is sure to get you flamed, but that was probably your intent.
  3. Lacero macrumors 604


    Jan 20, 2005
    In Network settings in System Preferences, configure IPv4 using DHCP with a Manual Address.

    Type in an IP address in the range of your local network for instance, to .120 or so.
  4. Larrycleve thread starter macrumors newbie

    Feb 7, 2005
    The saga continues

    Sorry if my bashing apple offended anyone. I'm po'd because we bought this computer last October for my 87 year old mother to access the internet. The idea of getting an apple was that we would just plug it in and connect to the internet. So far she's hardly been on at all. The router isn't the problem as we have a windows laptop that connects wirelessly to the internet instantly. We took the apple computer to the apple store. At first it wouldn't connect to the internet there, but they put in a new location and it worked fine. We take it home and it doesn't work. I spoke with apple tech support, we tried several things that didn't work. He said the next step would be to reinstall the operating system which would be a lengthy process. If that didn't work then it was a hardware issue. He said before doing that to call dlink as the router might need special settings to work with an apple. The dlink tech person said that an apple should work with the default settings of the router. We put in a new location in network and the apple wasn't automatically picking up the router's ip address which it should have done. We manually put in the router's ip address and the apple was able to access the router's config menu through safari. It still couldn't access the internet so dlinkk said it was an issue with the computer. I called apple tech support back. I was on hold for ten minutes, gave the case number, and was transferred to a higher level tech. After being on hold for 15 minutes with no answer I hung up and will try later today. I will let everyone know the outcome when this gets resolved,.
  5. Blue Velvet Moderator emeritus

    Jul 4, 2004
    Just because it's lengthy doesn't mean it should be ignored...

    Besides, it's not that lengthy a process... this isn't Windows.

    Sometimes the OS install that comes out of the box is a little flaky. It should take around 20-30mins.

    Just backup the Users folder onto a CD or something larger... then do an archive & install.
  6. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    If it was working and suddenly stops in the future, the first thing to do is just unplug the router and plug it back in again (it's worth checking that your router's firmware is up to date)

    Try this - I had a similar problem with a dlink.

    Turn off everything and wait for 10 minutes (this way you may wait for 2 or 3 ;) )

    Then turn the modem back on and wait for a minute

    Turn the router back on and wait for a minute

    Turn the Mac/PCs on and see what happens.
  7. Larrycleve thread starter macrumors newbie

    Feb 7, 2005
    It's working!

    It's working! I called apple tech support and we spent an hour doing various software and hardware resets including removing and reseating the airport card. Then I did a hard reset of the router using the paper clip in the reset hole. It's even connecting to the router at bootup. Could this be the end of months of frustration? Will batman catch the joker? Stay tuned for next weeks show. I'll let everyone know next week if this is able to stay working for a week straight. Fingers are crossed!
  8. ftaok macrumors 603


    Jan 23, 2002
    East Coast
    Be careful with the reset router. It's now back to the factory default settings, which means that it's out in the open for anyone to see. You should go into the router and redo any security measures that you had previously had turned on (i.e. WEP/WPA encryption, MAC filtering, etc.)/

Share This Page