Problems accessing home emails from work

Discussion in 'iPhone' started by CloudDweller, Jun 29, 2010.

  1. CloudDweller macrumors newbie

    Joined:
    Aug 13, 2009
    #1
    I have a Google Apps account and I have setup my iPhone to fetch emails once every hour. Now if I'm at home on wifi or I use my cellular signal, the phone will fetch my emails every hour. However when at work and connected to the work wifi then it doesn't fetch. If I manually try to pickup my emails I get the following error message

    "imap.gmail.com is not responding"

    If I disconnect from my work’s wifi and use the cellular signal then I can fetch fine. This also seems to be the base on my MacBook and my colleague’s iPad using our works wifi. Does anybody know why this would be happing and how to resolve it? It’s probably some security settings on exchange server but I’m not too sure.
     
  2. T4R06 macrumors 65816

    Joined:
    Oct 8, 2007
    Location:
    CT
    #2
    i do have gmail account too but im not using the imap.

    do this:
    setup your gmail account as exchange. since iphone 4 now supports multiple exchange account.
    input all the credentials you have and
    your server will be "m.google.com"

    bonus part is your gmail now has push feature :)

    hope it helps
     
  3. b-rad g macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #3
    I am having the same exact problem on my Yahoo account. I even tried to delete account and start over but now when it tries to verify me cedentials i get the imap error.
     
  4. CloudDweller thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #4
    Thanks for the reply. However, I don't want to use Exchange on my iPhone as it doesn't support editable drafts and email search on the server. As soon as it does I will be switching, but until then I need to use IMAP. Also it doesn't work on my MacBook and I don't have the option for exchange on iCal in OS X 10.6 so it has to be IMAP.
     
  5. Interpolation macrumors regular

    Joined:
    Jan 11, 2008
    #5
    If it's not working on a few devices, then your work is blocking it.
     
  6. CloudDweller thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #6
    If my work is blocking it, do you know how to go about stopping this?
     
  7. sarcosis macrumors 6502a

    Joined:
    Apr 25, 2006
    Location:
    These United States
    #7
    You will probably want to talk to your IT Admin about this. There might be port blocking or address blocking that they have on your LAN. If you are getting it fine via 3G and at home, it's not your phone's settings, it's the LAN that you are on at work. It's possible that they don't want any loose IMAP callouts on the network.
     
  8. gloss macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #8
    The easiest thing would be just to use 3G. Otherwise, you'll need to talk to IT to get it figured out.
     
  9. CloudDweller thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #9
    Okay thanks to everyone for all your help. I'll go and have a chat with my IT guys.
     
  10. Geez1234 macrumors newbie

    Joined:
    Jun 21, 2010
    #10
    I have the same issue with gmail. My school wifi and another wifi network that I use a lot keep me from accessing my mail.
     

Share This Page