Problems after update

Discussion in 'macOS' started by Mr.Texor, Mar 19, 2008.

  1. Mr.Texor macrumors regular

    Joined:
    Apr 20, 2007
    #1
    Almost none of the apps will run after update. Some will run only for a while and then crash. Here's part of 2 crash reports

    Code:
    Process:         Activity Monitor [249]
    Path:            /Applications/Utilities/Activity Monitor.app/Contents/MacOS/Activity Monitor
    Identifier:      com.apple.ActivityMonitor
    Version:         10.5 (118)
    Build Info:      ActivityMonitor-1180000~7
    Code Type:       PPC (Native)
    Parent Process:  launchd [78]
    
    Date/Time:       2008-03-20 00:55:33.710 -0500
    OS Version:      Mac OS X 10.5.2 (9C7010)
    Report Version:  6
    
    Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes: 0x0000000000000002, 0x0000000090707b44
    Crashed Thread:  0
    
    Thread 0 Crashed:
    0   libicucore.A.dylib            	0x90707b44 unum_formatInt64 + 0
    
    
    
    
    
    Process:         Safari [115]
    Path:            /Applications/Safari.app/Contents/MacOS/Safari
    Identifier:      com.apple.Safari
    Version:         3.1 (5525.13)
    Build Info:      WebBrowser-55251300~1
    Code Type:       PPC (Native)
    Parent Process:  launchd [78]
    
    Date/Time:       2008-03-20 00:50:01.617 -0500
    OS Version:      Mac OS X 10.5.2 (9C7010)
    Report Version:  6
    
    Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes: 0x0000000000000002, 0x0000000090709548
    Crashed Thread:  0
    
    Thread 0 Crashed:
    0   libicucore.A.dylib            	0x90709548 uidna_IDNToUnicode + 8

    seems libicucore is crashing all of them... anyone has the same problem? or knows how to fix them?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Which update? If it's a Mac OS X update, try installing the appropriate Combo Update over top of what you have.
     
  3. Mr.Texor thread starter macrumors regular

    Joined:
    Apr 20, 2007
    #3
    Is there anyway to do this using terminal? I cant open any Finder windows because they crash too. I tried mounting a dmg file, but I couldnt find the mount point aftwards... :'(
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    There is, but you may need to download the appropriate combo update first. If you don't have it. If that isn't going to work, then I'd recommend an Archive and Install (with the Preserve Users and Network Settings box checked) of your system from the install CDs/DVD.
     
  5. Mr.Texor thread starter macrumors regular

    Joined:
    Apr 20, 2007
    #5
    I got the dmg file already on my mac mini.. the problem is, I cant mount it.

    in terminal I tried something like this:

    diskutility mountDisk file.dmg

    it worked, but it didnt give me a mount point. I tried looking for it, but couldnt find it either. maybe, I got something wrong on my command...
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    The mount point for disk images is /Volumes/imagename (which may be different from the filename).
     
  7. Mr.Texor thread starter macrumors regular

    Joined:
    Apr 20, 2007
    #7
    I was using the wrong util to mount the disk image... I was able to mount and find mount point.. now the problem is that I can't reinstall the pkg. It tells me volume is disabled and that it can not install..
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    If you're in Single-User Mode it defaults to a read-only mode to protect your system. There's a command you can use to enable writing, which you'll definitely need to do to install something... but I can't recall what it is.
     
  9. Mr.Texor thread starter macrumors regular

    Joined:
    Apr 20, 2007
    #9
    Hey, thanks wrldwzrd89, I was not able to get the pkg installed. I was able to mount the dmg file with the hdiutil and was able to get the drive as read/write using mount -wu /.

    Thank God tho, I was able to find my leopard disk and just used time machine to recover...



    thanks!
     

Share This Page