Problems Booting My Mac

Discussion in 'iMac' started by trellaine, Jun 17, 2013.

  1. trellaine, Jun 17, 2013
    Last edited: Jun 17, 2013

    trellaine macrumors member

    Joined:
    Jul 24, 2009
    #1
    A few days ago my mac wouldnt boot up. It is stuck at the grey screen with apple logo and spinning gear. I tried booting up in safe mode ala shift key but that doesnt seem to work.

    The Mac is probably 3-4yrs old. Just a guess. So its been through a bunch of updates. And it currently has mountain lion os.

    I will try booting up in safe mode again.

    Any thoughts or suggestions?

    Thanks

    Ps. When i try rebooting in safe mode the progress bar goes about 25%and then switches to grey screen with apple logo and spinning gear.
     
  2. Raima macrumors 6502

    Joined:
    Jan 21, 2010
    #2
    Hopefully it's just a hard drive failure in which you should be able to DIY replace the drive. Hope you've got backups

    Anything else and you may need to replace the logic board, which you may be better off getting a replacement mac.
     
  3. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #3
    Boot in verbose mode, and see if a disk check could help.
     
  4. trellaine thread starter macrumors member

    Joined:
    Jul 24, 2009
    #4
    I never heard any hdd noise etc. very strange. I tried D upon startup to being up diagnostics. No luck.

    What is verbose mode?

    Thanks eveyone.

    Luckily i have another imac i can use. Only a year old i think.

    ----------

    I entered verbose mode. I saw a whack of white text. But its stopped?

    Just text appears now. Doesnt appear to be any more progress than now.

    What next? Thanks

    ----------

    Last line of text says, "appleahcdisquequeuemanager: setpowerstate. And later says timed out after 100907 ms

    Thanks
     
  5. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #5
    fsck

    Follow this:
    http://support.apple.com/kb/ts1417
     
  6. trellaine thread starter macrumors member

    Joined:
    Jul 24, 2009
    #6
    Thanks. I was able to do that. After the five stages it appears my hdd is okay.

    *shrug*
     
  7. trellaine thread starter macrumors member

    Joined:
    Jul 24, 2009
    #7
    Follow up, hoping someone can interpret my findings.
    I made a mtn lion thumb drive.

    I booted up the mac. Option to install mtn lion overtop. It wouldnt let me.

    Checked disks with disk utility. Received errors trying to repair the disk.

    Verifying partition map, checking pre requisites. Problems found in partition map which may prevent booting (my issue)

    During repair process of my hd the following error, disk utility cant repair this, restore your backed up files. As well this message, reformat the disk, restore backed up files

    Am I hooped? Or any reason i would get these errors?

    My mac is 4yrs old. Sounds like i have to lose all current info on hd?

    Thanks for reading.
     
  8. trellaine thread starter macrumors member

    Joined:
    Jul 24, 2009
    #8
    Sigh, i completed the verify disk and repair disk. Everything is fine apparently yet all those error messages the first time i ran the checks.

    Ugh:confused:
     
  9. trellaine thread starter macrumors member

    Joined:
    Jul 24, 2009
    #9
    specs on imac and SSD? Fusion/Hybrid?

    Its been awhile but to someone who was asking the model etc of my imac. I am looking for a compatible SSD or fusion/hybrid.

    My imac model is 20" mid 2007, MA877LL
    2.4Ghz
    4mb shared L2 Cache
    up to 4gb RAM 667mhz ddr2


    I found a compatible SSD from Crucial part #CT3932392 but it does its compaitble and works BUT "no mounting solution".

    Anyone have experience or give me a suggestion to have this put in my imac? I am going to have this done or hope to this week.
     

Share This Page