Problems connecting to wireless network on Macbook Pro using D-Link Router

Discussion in 'MacBook Pro' started by Lisa2324, Dec 1, 2007.

  1. Lisa2324 macrumors newbie

    Joined:
    Dec 1, 2007
    #1
    I just recently bought a Macbook Pro 2.2 Ghz, and am having trouble getting it to connect to the internet with my WBR 1310 D-Link router. I have used the computer at other people's house and have been able to connect easily with no problem. I've come across similar problems with D-Link routers on forums but haven't found any fixes. The computer accepts my router password and shows that it's connected to the network, but won't access the internet. Any suggestions would be very appreciated.
     
  2. MacEver macrumors newbie

    Joined:
    Nov 29, 2007
    #2
    I have the same problem. Any Mac Gods here that could give us the answer?

    tx...
    MaCEvEr
     
  3. Lisa2324 thread starter macrumors newbie

    Joined:
    Dec 1, 2007
    #3
    MacEver,
    I just got mine to work. Not really sure how I did it, but as I was trying to install different firmware on the router, my router would no longer connect to my PC either. I unplugged and reset my router, and when I got it re-setup on the PC, it began to work on my MAC. The only thing I can suggest is to do a reset on your router and see if that works.
     
  4. MacEver macrumors newbie

    Joined:
    Nov 29, 2007
    #4
    That's what I do...I always have to pull the plug and reset :(. I've updated the firmware already.

    Thanks...
    MacEver
     
  5. Jazzandmetal? macrumors regular

    Joined:
    Jan 24, 2008
    Location:
    Virginia
    #5
    d-link

    I just bought one and have to return it as it is faulty. I spent 1 hour on the phone with some guy in india and updated the firmware.....still, nothing. Oh well.:cool:
     

Share This Page