Problems connecting with MyWi

Discussion in 'iPad Hacks' started by Vinniefish, Apr 4, 2010.

  1. Vinniefish macrumors member

    Joined:
    Feb 18, 2009
    #1
    I installed MyWi (the no rock one) and I am unable to connect my iPad to it. I see the ssid on my iPad and it connects and I see the wifi symbol with 3 signal strength, but when I try to use safari an alert pops up saying there is no connection to the internet. Has anyone had this happen and figured out a way to connect? I have done a google search but came up with nothing. Thanks for the help!
     
  2. OneMike macrumors 603

    OneMike

    Joined:
    Oct 19, 2005
  3. xStatiCa macrumors regular

    Joined:
    Oct 7, 2009
    #3
    I have the same problem with the iPad and a buffalo wireless-n router. The same router works fine with my macbook air so it doesn't make much sense. What settings are you using? I am using wireless-n only on the buffalo router. The iPad is wireless-n capable so again... it doesn't make much sense.

    With the buffalo router it connects and shows the signal strength as good but it can never get a DHCP address.

    My netgear g router works just fine with the iPad.
     
  4. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #4
    Have you connected any other machine (MacBook or whatever) via MyWi? ...Just wondered if you're certain it's working.

    MyWi sets up an ad hoc network. I wonder if the iPad supports that.
     
  5. Romanesq macrumors 6502a

    Romanesq

    Joined:
    Jun 16, 2003
    Location:
    Hoboken
    #5
    Yes

    It does work as it was my first question. Did the black rain and made it rain, then installed rock my phone and then installed mywi right on the iPhone 3GS. Have to do it on the phone with OS 3.2.

    Used it right after sync at a restaurant. Worked great and without fail several times already around town. First time trying and using this. Flawless.

    Sent via iPad. :cool:
     
  6. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
    #6
    I reset the iPhone, then tried to do it again but signal strength is now only 1 and still had the same alert the safari could not connect. I then tried to connect to the network with my MacBook but that did not work either, it said that it had a self assigned ip address. Any help?
     
  7. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
  8. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #8
    Are you giving it enough time to fully negotiate a connection? I note that my MacBook Pro takes almost a minute to complete its connection to my MyWi-running jailbroken (by BlackRa1n) iPhone 3G (running OS 3.1.2).

    I understand Romanesq's post to mean that his iPad connects via MiWi wireless tethering to his iPhone. That's promising; I was afraid there was something about the iPad's wifi implementation that wouldn't support ad hoc.

    Your OS 3.0.1 should be fine. Gotta be something else.

    Are you using WEP? For now, turn that off until we get things working. One less borkable factor in the equation...
     
  9. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
    #9
    I've given it over a minute to connect to and the connection seems to go through. I have read that mywi needs at least 3.1 to work, I am trying to update it to 3.1 now to see if that is the issue. I have tried with wep and without wep with the same result.
     
  10. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #10
    Well if there's some authoritative statement somewhere that 3.1 is necessary, then maybe that explains it. I thought anything above 3 would work, but I'm not an expert. Good luck on your upgrade, then!
     
  11. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
    #11
    Okay just wanted to give anyone reading this thread an update. I updated my iPhone to 3.1.2 with pwnage tool and it works now, it seems that the problem was that I was running 3.0.1. so if anyone else runs into this problem they should try this method. It is nice to not have to buy the 3g version of the ipad considering I already pay for 3g service on my iphone. The thing that irks me about this is I would gladly pay $10 more a month for this ability since I won't be using my iphone's and ipad internet at the same time.
     
  12. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #12
    Thanks for the update-- very helpful, I learned something and others will too.
     
  13. yaroldb macrumors 6502

    Joined:
    Feb 21, 2007
    #13
    That is my problem. A million thank you's. I've tried everything and could not figure it out. How did you upgrade to 3.1.2? I have 3.0.2. Any link or video with instructions is greatly appriciated.

    Thanks...
     
  14. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
    #14
    What I did was download pwnage tool, the 3.1.2 ipsw (this is the firmware), then I ran pwnage tool and it found the firmware and proceeded to create a custom firmware of 3.1.2. Then you go to iTunes and hit option (if you are on a mac) and select the custom firmware pwnage tool created. it will restore your iphone to the hacked 3.1.2 and you should be good to go. Google is your friend in this and remember that you will have to load all content back onto your phone afterwards since it did a restore to factory conditions but in a jailbroken state. Please let me know if this works for you and I must say that once you get it working that it is awesome. Webpages load faster on the iPad then on the iphone plus you don't need the 3g version of the iPad.
     
  15. yaroldb macrumors 6502

    Joined:
    Feb 21, 2007
    #15
    What version of Itunes did you do this on? I am leaving work in a few and getting home to try it. Thanks again...
     
  16. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
  17. yaroldb macrumors 6502

    Joined:
    Feb 21, 2007
    #17
    Oh no, I upgraded. It worked but now I can not connect to AT&T. No phone service. This is not good.
     
  18. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
    #18
    Not to worry, just do the upgrade process again and when it asks you if you need carrier activation choose yes. The same thing happened to me, sorry I should of mentioned it but I honestly forgot that it happened, but you didn't mess anything up. Let me know how it goes after that.
     
  19. yaroldb macrumors 6502

    Joined:
    Feb 21, 2007
    #19
    Vinniefish,

    You are the best, it's working. Like a champ. This is awesome. I've been fighting it for 6 days and thanks to you I am surfing on my iPad with my 3G iPhone. Thank you, thank you, thank you, thank you.....
     
  20. Vinniefish thread starter macrumors member

    Joined:
    Feb 18, 2009
    #20
    No problem, glad I was able to help. I hope you enjoy it, I know I have been enjoying it. I was originally not going to get the iPad but once I played with it in-store I was hooked. I was patiently waiting for the updated Macbook Pro but now that I have the iPad I think I may have changed my mind.
     
  21. thundermustard macrumors regular

    Joined:
    Apr 21, 2008
    #21
    OK I am in the same boat, get this message

    AirPort has the self-assigned IP address 169.254.97.152 and will not be able to connect to the Internet.

    I wait over a minute, still no connection. It works only via USB.

    My iPhone is a 3GS with 3.1.2 and jailbroken with BlackRa1n.

    Any other ideas, by the way, it does the exact same thing with my wife's on her 3G regardless of which of our two MacBooks I try.
     
  22. cpnotebook80 macrumors 6502a

    Joined:
    Feb 4, 2007
    Location:
    Toronto
    #22
    I disable WEP and it works for me.
    I read on apple support forum regarding WEP and they recommended using WPA.
    Since myfi doesnt have WPA I just disabled it.

    It seems to making the ipad wifi unstable.


    http://support.apple.com/kb/ts3304

    See link. Also, renew lease seems to get things working.
     

Share This Page