Problems copying files to external drive

Discussion in 'OS X Mountain Lion (10.8)' started by Jezinio, Oct 18, 2012.

  1. Jezinio macrumors newbie

    Feb 19, 2012
    Hi - I've got a really frustrating problem trying to copy files to an external drive. I have thousands of files and most copy fine when I drag to the external drive. However I am getting seemingly random error messages either saying the file cannot be copied because it is in use (they are not in use) or 'The finder can't complete the operation because some data in **** can't be read or written.

    the error code that keeps cropping up is -36

    I have checked all my priveleges and they are fine - read and write.

    The external drive format is also OK. It's not just one drive this happens on but any that I connect.

    I am also having trouble with Time Machine which fails in its back-up fairly early. I suspect this may be a similar problem

    Many thanks if you can help
  2. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    Error -36 is a disk I/O error and sometimes points to a failing drive.

    What format is the external drive? Try running repair disk from Disk Utility on both drives.
  3. Jezinio thread starter macrumors newbie

    Feb 19, 2012

    I'm pretty sure it's something to do with the files I'm trying to move rather than the drives. The problem even occurred when I tried to copy the files to my desktop.
  4. crowdson macrumors newbie

    Oct 19, 2012
    I've been having the same problem since 10.6. It's actually the reason I just upgraded to 10.8, but it's still happening. Some people are having success with this solution:
    but I haven't tried it yet since it assumes the problem is your drives are formatted as FAT volumes, and mine are all Mac OS Extended.
    It is happening on all my drives - USB, Firewire, and eSata - and seems to be related to file size. I'll follow up if I get any more info.

Share This Page