Problems Creating Bootable Windows 7 USB from Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by sh0td0wn, Jun 24, 2012.

  1. sh0td0wn macrumors newbie

    Joined:
    Jun 23, 2012
    #1
    Okay, I want to install Windows 7 on my 13" MacBook Air mid-2012 for school. I've searched everywhere already so I'm making a new thread for this. Since it has no DVD drive, I need to turn a USB key (some Lexar 4GB one) into a bootable one that contains Windows 7 installer. So what I did was:

    1. Get a copy of Windows 7 Pro from Dreamspark (MSDN).

    2. Use ISO in Boot Camp Assistant (4.0.4).

    3. Ends up stuck somewhere around 90% saying Copying Windows Files.. (I don't know if it's really 90% because I had to eyeball it; it was about 8/9ths done I guess).

    4. So I stopped it; took a look; there's the installer files and the files I'm used to seeing when I mount a Windows 7 ISO into a virtual drive.

    5. I thought that it was okay to use so I proceeded with creating a Windows partition in Boot Camp Assistant.

    6. Booted from the not so sure USB drive and the Windows Screen popped up. I then selected the regional settings then clicked Install Now. This shows up:

    "A required CD/DVD drive device driver is missing. If you have a floppy
    disk, CD, DVD, or USB flash drive, please insert it now. Note: If the windows
    installation media is in the CD/DVD drive, you can safely remove it for this
    step."

    7. I looked in the internet and someone from this forum said to pop out the drive and plug it in some other USB port. Other people from that thread said that idea worked.

    8. I tried the same steps from above but using a pirated copy (not really I wanted and if it worked, then okay) and I still got the same result with the not so finished bootable USB.

    Can anyone help me on this?
     
  2. monkeybagel macrumors 65816

    Joined:
    Jul 24, 2011
    Location:
    United States
    #2
    How long did you let it run before you cancelled it? It sounds like you cancelled it when it was copying the Install.wim file, which contains the OS files and would cause this behavior. If it is bootable, then it managed to do some of the process correctly.
     
  3. sh0td0wn thread starter macrumors newbie

    Joined:
    Jun 23, 2012
    #3
    Whoops! Yea you're right. Looks like I don't see that install.wim file anywhere in the drive. So I just let it wait then I guess?
     
  4. sh0td0wn thread starter macrumors newbie

    Joined:
    Jun 23, 2012
    #4
    Since the drive was already prepared by Boot Camp Assistant and it was just the install files wasn't properly copying to the drive, I just cleared all of the files on the USB and replaced it with the contents of ISO itself manually. When I booted from the USB, it installed Windows 7 flawlessly.

    Problem Solved :)
     

Share This Page