Problems deleting Time Machine backup backup

Discussion in 'macOS' started by babyj, Aug 21, 2008.

  1. babyj macrumors 6502a

    Joined:
    Aug 29, 2006
    #1
    I use Time Machine and backup to an external drive. I've got another external drive that I cloned the Time Machine drive to, using SuperDuper!. I needed some extra disk space so I decided I could do without the clone of the Time Machine drive for a while, so I deleted all the files from it and started using it for other stuff.

    Everything was fine until I ran out of space on the drive, as the old Time Machine files are still in the trash. No problem I thought, I've got Compost so that will clear the trash and everything will be fine. Except over 24 hours later they are still in the trash - something is happening as Compost and Finder are using a lot of cpu but no sign of the files being deleted yet.

    I'm guessing that the problem is the number of files - there is probably 100,000's due to the multiple copies / pointers and that it is going to take some time for it to finish. I've tried deleting them from the trash (I'm guessing the immediate delete option I'm using is the Compost context sensitive add on) but it won't let me.

    Anyone got any ideas as to how I can get rid of the files????
     
  2. Thomas Davie macrumors 6502

    Joined:
    Jan 20, 2004
    #2
    That happened to me. Reboot the computer and format/erase the drive.

    Tom
     

Share This Page