Problems downloading files - Safari & Firefox

germ war

macrumors member
Original poster
Dec 5, 2003
93
0
Saint Paul, MN
For a few weeks now, perhaps triggered by the 10.3.8 update, I've been trying to download the newest version of Adium. I've tried both Safari and Mozilla Firefox, but I'm having an unusual problem.

When I click the file to be downloaded, the download window never comes up in either browser. It just refreshes the page. I tried going to Mozilla.org to download something off their page (Firefox, Thunderbird, ANYTHING really...) and nothing would work - it would just refresh the page.

I've reset Safari, and nothing seems to help. Any ideas what might be causing this problem, and is anyone else experiencing a similar issue?
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,777
12
Grand Rapids, MI, USA
What happens when you try to download it using this link:

http://internap.dl.sourceforge.net/sourceforge/adium/AdiumX_0.77.dmg

Also, when you say that the download window doesn't come up, do you mean that it gets as far as the mirror page, but then just refreshes, or do you mean that you never even get to the mirror page from the main AdiumX page?

Try downloading it with your pop-up and ad- blockers disabled....Is it possible that the site somehow got on a content filter somewhere? I have 10.3.8 and FF1.0 with pop-up blocking enabled and AdBlock on, and I can download it.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.