Problems during upgrade with Samsung 840 series SSD

Discussion in 'MacBook Pro' started by punzel, Jan 10, 2013.

  1. punzel macrumors newbie

    Joined:
    Jan 10, 2013
    #1
    Hi!

    I decided to upgrade my MBP with a Samsung 840 series SSD (250 GB).
    Here is what I did:

    1) Connected the new SSD via usb.
    2) Formatted SSD with disk utility (Mac OS Extended (Journaled)).
    3) Used "restore" in disk utility to copy the original HDD to the new Samsung SSD.
    4) Shut down MBP.
    5) Started MBP with "alt" key held down - Both the original and the new disk where found.
    6) Choose the new SSD (connected via usb) as startup disk this time and OSX did boot just fine. Everything worked.
    7) Swapped the original HDD with the Samsung SSD.
    8 ) Started MBP - SSD was not found...

    I also started the MBP with the alt-cmd-r-p keys pressed, but that did not help.

    That means the new SSD is found and works fine as boot-disk when connected to usb, but not when connected internally.

    Does anyone know what might be the problem?
    I'll be very happy about any suggestion.

    Here is some info about the laptop:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro5,5
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.53 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 4 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: MBP55.00AC.B03
    SMC Version (system): 1.47f2
    Serial Number (system): W89393K266E
    Hardware UUID: A63ACC15-D2B4-567E-9413-3E3AEF3EACB4
    Sudden Motion Sensor:
    State: Enabled
     
  2. ezramoore macrumors 6502a

    Joined:
    Mar 20, 2006
    Location:
    Washington State
    #2
    Unless I missed something obvious I would say you might have a dead HDD cable. The cable that connects the HDD to the logic board has a pretty high rate of failure in your model. The good news is that they are cheap and not too difficult to replace.

    Try putting your old HDD back in and check to see if it boots.

    If not, I strongly suspect that cable is the problem. It could potentially be the logic board, but I think that unlikely at this point.
     
  3. Limey77 macrumors regular

    Joined:
    Apr 22, 2010
    #3
    I'm no expert in this at all, but I am about to attempt exactly the same upgrade myself on Saturday.

    My understanding is that you can either install the blank formatted ssd into the main bay and restore the OS over the internet or you can do it the way you have done.

    If you do it the way you have, then you need to make sure you select the correct drive as the boot disk. My guess is that since you booted the computer from the ssd via USB that it is looking for that drive over USB and not from the main bay.

    Try connecting your old hard drive via USB to boot the computer and then double check you have the correct drive selected as the boot drive.

    Having never tried this I don't know if it'll work, but I have read of people having similar problems.
     
  4. punzel thread starter macrumors newbie

    Joined:
    Jan 10, 2013
    #4
    ezramoore, thanks for the answer. Putting the old HDD back was the first thing I did . no problem booting up.

    Limey77, I will try that and let you know, if it works.
     
  5. Macaddict44 macrumors newbie

    Joined:
    Feb 8, 2011
    #5
    Didn't have a problem with this method on a slightly newer MBP same sssd.
    I would boot it to an osx thumb drive and see if the drive can be formatted using disk util while internal.
    There is a firmware update for that drive, and you are going from a sata3 drive to a sata2 controller. Sometimes there are issues. That mbp is sata2 isn't it?
     
  6. Shaddow825 macrumors 6502

    Joined:
    Mar 13, 2006
    #6
    Boot with the alt/option key held down and see if it lets you choose drives to boot from

    ----------

    Also, try connecting your HD via usb and holding down alt/option to boot from it and see if disk utility sees the SSD in the mainbay, and then choose it as the startup disk if it does.
     
  7. sahni130 macrumors 6502

    sahni130

    Joined:
    Jun 25, 2008
    Location:
    Atlanta, Georgia, United States
    #7
    I had the same issue when I was installing my 830. The SSD just needs to be formatted in disk utility and then it should be "good to go".
     
  8. jamin100 macrumors 6502

    Joined:
    Sep 22, 2008
    #8
    You need to select the a guid partition map when you format it in utility
     
  9. punzel thread starter macrumors newbie

    Joined:
    Jan 10, 2013
    #9
    jamin100, good point. I actually did select guid partition map and when I check the disk in the system profiler it also shows guid partition map for the SSD.

    Shaddow825, I did hold the alt key when starting up - I get both disk when the old HDD is in the internal bay and the SSD is connected via usb. I get none of the disks, when the SSD is in the internal bay and the old HDD is connected via usb.

    Macaddict44, you might have two good points there that I should check. I tried to use the Samsung software with a windos pc. The SSD was connected to a SATA-usb (external), but I could not update the firmware (not because there wasn't a newer firmware version, but because it would not even search for this disk). Maybe I will have to connect the disk internally for the Samsung software to accept the disk?
    The other thing to check might be, if the problem comes from some incompatibility. It says SATA 6GB on the disk (also it says 3GB compatible). However, the system profiler shows a SATA Link speed of 3GB with a negotiated linkspeed of only 1.5GB. Maybe the disk will only accept 6GB or 3GB, while the MBP wants to go down to 1.5GB (which the disk won't support)?

    Does anyone know, if the last point might be the problem? If it might be, are there any ideas about if/how to solve this?
     
  10. Shaddow825 macrumors 6502

    Joined:
    Mar 13, 2006
    #10
    I believe this last part is the problem. I think that rev of the macbook pro has the NVidia MCP79 chipset. It has a problem negotiating with 6gbit drives and wont negotiate 3gbit with them, only 1.5gbit. If the 840 won't do 1.5 then that's your problem. I do not know if this problem is limited to sandforce based drives or not (of which samsung is not one) as I only had a vertex3 and I didnt have to research the problem much more than that.

    OCZ on the vertex3 6gbit drives actually created a utility that locks them into 3gbit so they won't try to negotiate 6gbit and fail back to 1.5.
     
  11. Shaddow825 macrumors 6502

    Joined:
    Mar 13, 2006
    #11

Share This Page