Problems emailing to Japanese aU phones from UK iPhone.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by GavinT, Aug 18, 2008.

  1. GavinT macrumors member

    #1
    My wife is having problems with sending emails to her friends back in Japan, as the emails keep ending up as 'mojibake' (jibberish escape characters).

    Set up is as follows.
    She's using a iPhone on the UK 02 network (as do I).
    She has a Yahoo email account (set up via Yahoo's UK portal).
    I have the same setup.
    Her phone is running with Japanese as the language, as well as using Japanese keyboard.
    My phone is running in English, but with Japanese keyboard enabled as well as English-UK.

    Now, we can send Japanese mail to each other with no problems on the O2 network.

    The problem is when she sends back to Japan.
    When she sends to a friend who has a 'PHS' type phone, the subject of the email ends up as jibberish but the message body is fine.
    When she sends to friends and family on aU phones, the whole lot is jibberish.
    I don't know what happens when she sends to DoCoMo or non-iPhone Softbank friends.

    She had read that aU is using Shift-JIS rather than UTF-8 as the encoding mechanism (grrr!!! :( ), but I can't see anyway way of changing this on the phone.

    Anybody had similar issues (either Japanese Softbank iPhone to other non-iPhones in Japan... or outside of Japan iPhones to Japanese phones)??

    Cheers,
     
  2. Raseru macrumors newbie

    Joined:
    Sep 19, 2008
    #2
    This topic is a bit old but I'm having the exact same problem too. AU phones only recognize shift-jis which is just a joke. I need to be able to email them but is it even possible with the iphone? It is pretty sad that I can't change the encoding on iphone, at least not to my knowledege...
     

Share This Page