Problems Installing EVERYTHING

Discussion in 'macOS' started by arvincor, Mar 19, 2013.

  1. arvincor macrumors newbie

    Joined:
    Mar 19, 2013
    #1
    Recently realized that my MBP (10.6.7) keeps getting the installation failed error message every time I try to install from a .mpkg. I also get the same error when I try to update to 10.6.8 (via Software Update AND the combo update downloaded directly from the Apple website). I also can't install any apps from the app store.

    I've already looked extensively into the issue to no avail. I've tried to epair disk permissions from the Snow Leopard DVD. Someone told me my downloads were getting corrupted so I've also re-downloaded files (in safe mode, after rebooting router and modem, ethernet directly to router then modem, on another wifi network).

    Any help would be appreciated.
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    Forget Repair Permissions. Repairing the Disk, while booted to the installer disk would be useful.

    Are you running as an Admin user? Can you authorise stuff successfully, and use "sudo" in the Terminal? (Type "sudo ls" and type return. You will be asked for your password. You should then get a listing for the current directory.)

    Are there any relevant messages in the system logs when installation fails? You can find these in the Console app in the Utilities folder.
     
  3. arvincor, Mar 19, 2013
    Last edited by a moderator: Mar 19, 2013

    arvincor thread starter macrumors newbie

    Joined:
    Mar 19, 2013
    #3
    Sorry, I should've mentioned that I have gone through both the Repair Disk and the Repair Permissions processes. I tried again in the last hour and everything checks out. I've attached screenshots of the console messages when trying to update, trying to install an app, and also trying to install from a .pkg file.

    Also, yes my account is admin and I can use "sudo" in the Terminal.
     

    Attached Files:

  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    Have you got any installers on a shop-bought disk that you can try? Or an archived installer that you know has worked in the past?
    My thought is: is it a problem with downloading large files successfully, or is it a problem with installing?

    To me, the Console logs suggest that there's a problem with the file that has been downloaded.
     
  5. arvincor thread starter macrumors newbie

    Joined:
    Mar 19, 2013
    #5
    Just tried uninstalling and reinstalling a software that I still had the .pkg file for. It installed fine. So I guess my downloads are getting corrupted. Again, I've tried Software Update on other networks with the same result though.
     
  6. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #6
    Let's make a list of what we (think we) know:
    • Old installers work fine.
    • The Disk is not corrupt or failing.
    • Downloading from other networks also produces installers that don't work.
    • Using Ethernet cable instead of wireless also doesn't work.
    Weird. Have you tested a brand new user account? If the problem persists there, then I can only suggest re-installing the OS. If it doesn't, then you have pinpointed the cause as something inside your original user's Library folder.
     
  7. arvincor thread starter macrumors newbie

    Joined:
    Mar 19, 2013
    #7
    Good news. My problems seem to be all fixed. I reinstalled Snow Leopard and it went back to 10.6.0. After that I was able to install the 10.6.8 combo update and finally bumped it up to Mountain Lion. Was 10.6.7 notoriously buggy or something? The software I was initially trying to install works now as well. Thanks for the help.
     

Share This Page