Problems installing macOS Sierra Public Beta 3

Discussion in 'macOS Sierra (10.12)' started by DanEp, Aug 2, 2016.

  1. DanEp macrumors member

    Joined:
    Jan 7, 2012
    #1
    I had previously configured the App Store to download updates but wait for me to install them. It looks like it successfully downloaded the macOS Sierra Public Beta 3 update to /Library/Updates/031-69393/ and then the App Store requested that I install it. When I said yes to install, App Store went to Installing but then hangs at "0 bytes of 2.05 GB -- Calculating.."

    After a while, I Quit that, rebooted, and then tried:

    sudo softwareupdate -i "macOS Sierra Public Beta-3" --verbose --force

    and I saw no activity using task manager.

    After a while, I moved the /Library/Updates/031-69393/ to /tmp, rebooted and tried again all of the above. No dice. Hangs at 0 or at "Installing -- Calculating.." in App Store.

    Also tried App Store Check for Unfinished Downloads of which there were none.

    Any advice?
     
  2. DanEp thread starter macrumors member

    Joined:
    Jan 7, 2012
    #3
    Tried this and then update disappeared. Not available from App Store and command line also reports No Updates are Available.

    So I set the catalog back to the previous state (not so easy -- had to look in a plist file on another beta system). Then update once again shows but with same problem.

    When I manually download the 4 files and then run update, I am prompted to reboot but when I try to reboot I get an error message, "Available updates have changed. ...." and it will not install.
     
  3. Scary Spice macrumors regular

    Scary Spice

    Joined:
    Jul 31, 2015
    Location:
    British Columbia
  4. TheAustrianGuy macrumors regular

    Joined:
    Apr 20, 2010
    #5
    Same here.
    Deleting the /Library/Updates/031-69393/ folder wil reset this, and the download will start again, but will get stuck again at 2.03GB.

    As far as I can see, I get the firmwarewhatever file, the main macOS file (almost 2GB), but I'm missing the
    FullBundleUpdate.pkg file which should be part of the installation.

    Any ideas?
     
  5. DanEp thread starter macrumors member

    Joined:
    Jan 7, 2012
    #6
    I was finally successful but can't recommend an exact procedure. I repeated deleting all files in /Library/Updates and rebooting. Eventually it worked, downloaded/installed Public Beta 3 after having the same problem you had (mine stopped at 151MB for some strange reason).

    I updated 3 systems. No problems updating two Macbooc Airs (late 2011 and early 2014). The problem occurred with my late 2011 Mac Mini. Had similar problems updating to macOS Sierra Public Beta 2 a few weeks ago on the Mac Mini only. This was a time-consuming and unpleasant experience.
     
  6. dypeterc macrumors regular

    Joined:
    Mar 5, 2012
    #7
    In same boat...

    Submitted feedback to Apple but even that's buggy. Timed out on submission...
     

    Attached Files:

  7. TheAustrianGuy macrumors regular

    Joined:
    Apr 20, 2010
    #8
    Yeah, I submitted one, too :)
    However, turned on the MBP this morning, and a message popped up not a minute later that updates are ready to install. Checked and seemed to be the PB3. Clicked "Update", and the update was installed without further issues.

    So this issue may go away eventually for you.
     
  8. dypeterc macrumors regular

    Joined:
    Mar 5, 2012
    #10
    No go for me this morning. I reinstalled the PB from the Purchased tab. I think it pulled down PB3 because it's not bringing up anything in SW Update. I'm on 269f.
     
  9. stradify macrumors member

    Joined:
    Jul 4, 2015
    Location:
    USA
    #11
    After experiencing a few aborted attempts to d'load PB3, 0K showing as having been d'loaded, it finally installed in spite of the fact that the third time I tried it showed 0K.
    Unfortunately I ended up with an installation that had no ability to connect to the internet either by wifi or ethernet.
    PB2 was fine in all regards. PB3 for me is a "no go".
     

Share This Page