Problems installing older SATA drive in new MBP

Discussion in 'MacBook Pro' started by Digidesign, Jun 2, 2009.

  1. Digidesign macrumors 6502

    Joined:
    Jan 7, 2002
    #1
    I got a new 2.93 macbook pro with the 320gb 7200rpm drive and it runs fine. I have an older 100gb SATA Seagate notebook drive that I wanted to use as a backup drive, so my goal was to use the old drive in the new MBP. The rest of this post is my frustrating journey of failure. First off, I put in the install disc with OS X, shut down, swapped drives and rebooted, holding down C to boot to the disc.

    The disc never boots, and the screen stays gray.

    The old drive works fine in my thinkpad, and has run Windows, OS X and Ubuntu. Thinking that it may be a drive partition issue (GRUB or whatnot) I booted OS X on my thinkpad and formatted the old drive as 1 GUID partition. Also tried MBR partition. Neither works.

    No matter what, the computer never boots to the install disc when the old drive is connected. When I disconnect the drive, it boots to the install disc fine. I've even tried my Leopard disc, not the machine-specific disc that came with the MBP. Neither one would boot with the old drive connected.

    I've tried holding down 'C'
    I've tried booting in single-user mode and running fsck -fy and /bin/fsck -fy. It always runs the check on the disc, not the hard drive.

    It would seem like the old drive is just dead, the way OS X just can't boot or recognize it, but the weird thing is that the old drive works just fine in other machines. It's a Seagate SATA 2.5" 7200rpm 100GB drive, which to me seems like it should have been an easy swap into the new MBP.

    Any help would be appreciated. As a last resort, I'm thinking of purchasing a firewire 400/800 cable and connect my MBP with the old drive inside to my MacPro. Then install OS X from the MacPro to the MBP through target mode.
     
  2. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #2
    It sure sounds like a hardware problem. That's the behavior when a disk goes bad enough to cause the SATA bus to be "hung". I expect that putting it into an external firewire enclosure would work. I thought there was only one SATA spec, so I'm surprised it didn't work. It fit the connector in the MBP correctly, right?
     
  3. Digidesign thread starter macrumors 6502

    Joined:
    Jan 7, 2002
    #3
    Yes, the old drive fits the connector cable perfectly. I'm also boggled since I thought that SATA was pretty universal.

    I might have to go the route of an external enclosure for the extra drive. Thanks.
     
  4. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #4
    One other thought. I know the MBP supports SATA2, maybe the older drive is SATA1 and there is a compatibility issue?
     
  5. Thiol macrumors 6502a

    Thiol

    Joined:
    Jan 26, 2008
    #5
    Should be back compatible. The scary thing is that the MBP isn't even booting to the Install CD...
     
  6. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #6
    That's a symptom of a bad drive. Everytime I've had a SATA drive fail in a MBP it hangs the SATA bus so that you can't use the DVD drive. Once the bad drive is removed everything works fine. In this case it doesn't sound like the drive is failed, but there is some sort of incompatibility.
     
  7. Digidesign thread starter macrumors 6502

    Joined:
    Jan 7, 2002
    #7
    Assuming it's not an incompatibility with SATA and the drive is not faulty, it *might* be a problem with the partition table/bootloader + GRUB.

    The weird thing is, even booting with an Ubuntu CD with the drive connected also hangs. When the drive is disconnected the Ubuntu disc loads.

    This UMBP just seems to hate this old drive. I will try some disk wiping programs tonight and will update. Thanks for the help so far.
     
  8. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #8
    For the amount of hours you've spent (wasted) on this, you could have purchased a new 320GB hard drive and just left the 100GB in some external housing. If the intent was to have the 100GB as a backup, why wouldn't you just clone the thing and leave it external for emergencies.

    Unless this is just an exercise for your own gratification in getting this to work, seems to be a waste of your time.

    Of course it is your time to waste...

    Cheers,
     
  9. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #9
    I wish I knew the reason but it sure sounds like it's hardware. I don't think there is anything you can do with formatting to get the drive to work.
     

Share This Page