Problems installing on external drive

Discussion in 'OS X Yosemite (10.10)' started by Roller, Jul 26, 2014.

  1. Roller macrumors 68020

    Joined:
    Jun 25, 2003
    #1
    To avoid issues installing Yosemite on a partition, I thought I'd try an external drive, which I assumed would be safer. I mounted the external (FireWire through a Thunderbolt adapter) and ran the installer from my iMac's internal fusion drive. The installer hung with 14 minutes remaining. After an hour or so, I quit, figuring that I could reboot off the internal after selecting it as the startup drive.

    However, every time I restarted, the Yosemite installer ran. The only fix I found was to reboot in recovery mode and reinstall Mavericks on the internal drive. That let me restart in 10.9, but took a long time.

    I've since read that the Yosemite installation may take hours, so I may just not have waited long enough. But if I run into the same problem again and want to abort the external installation, is there any way to reboot off the internal drive in Mavericks without reinstalling the OS?
     
  2. TruckdriverSean, Jul 26, 2014
    Last edited: Jul 26, 2014

    TruckdriverSean macrumors 6502a

    Joined:
    Feb 28, 2009
    Location:
    Texas, US
    #2
    Ran into a somewhat similar issue last night installing on a 2nd internal drive.

    Installation went fine, but main HD was stuck on Yosemite Installer when rebooted. Freaked me out with all the reports of nuked partitions.

    Finally I just let the installer finish its progress bar thing, and from the menu bar at the top, "quit Installer".

    Reboot and back to normal.


    This is probably why I'm on the PUBLIC beta. Lol
     
  3. ferryfb macrumors newbie

    Joined:
    Jul 26, 2014
    #3
    Same problem here. Eternal reboots without advance. I tried installing Yosemite on a SD card and it worked (but slow as hell, of course).

    Anyone has a solution or should I wait until the Golden Master yo install it ...
     
  4. Voch macrumors member

    Joined:
    Jan 27, 2006
    #4
    I had problems installing Yosemite on an old external FireWire 400 desktop drive.

    After installing using the installer in my Applications folder to the external drive my Mac failed to boot from the external drive after the initial installation copy-to-drive (it got stuck on the gray progress dialog about halfway). Same if I booted the Yosemite installer from an SD card.

    I did finally get Yosemite installed and bootable on the external drive after disabling my internal drives by unplugging them from the motherboard. I then reconnected the the internal drive cables and now cannot boot Yosemite from the external drive (same progress dialog as during the install attempt). And when running Mavericks from the internal drives the external drive with Yosemite installed won't even mount via FireWire.

    My machine is an early 2011 MBP with a homebrew Fusion setup (120GB OWC SSD + OEM 500GB HD) with FileVault enabled and running Mavericks 10.9.4. I wonder if the Fusion drive setup or FileVault is confusing Yosemite in some way.

    I'm not too worried about all this...I'm back to day-to-day operations in Mavericks on my internal Fusion setup. It's just all very strange.
     
  5. Roller thread starter macrumors 68020

    Joined:
    Jun 25, 2003
    #5
    I tried another installation on the external FireWire drive yesterday, and this time it completed in about 20 minutes. Now I can select either it or my fusion drive with 10.9 to boot. I think that the issue is that the installer does something to ensure that it'll run until it completes its process, even on an external drive, no matter what.

    As I said, my solution was to reinstall Mavericks in recovery mode, though that took a while. If there's a faster way using Terminal commands, it would be helpful to know.
     
  6. declandio macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    London, UK
    #6
    I installed with no problem onto an external drive, but when I rebooted 'normally', the 10.10 installer wanted to run again... just reboot and hold down the option key, select your normal startup disk and all will be fine. No need to reinstall anything!
     
  7. TruckdriverSean macrumors 6502a

    Joined:
    Feb 28, 2009
    Location:
    Texas, US
    #7
    Select the normal HD, let the installer boot up with its slow progress bar, then quit the Installer from the top menu bar.

    Reboot and done.
     
  8. Roller thread starter macrumors 68020

    Joined:
    Jun 25, 2003
    #8
    That was the first thing I tried - multiple times. It got me to the 10.9 login screen, but after I entered my password the installer loaded again.
     
  9. Saturn1217 macrumors 6502a

    Joined:
    Apr 28, 2008
    #9
    Do you think it has anything to do with the external being a firewire drive? I tried on a usb3 drive and I didn't have any issues (I guess it did restart a couple times during installation but it didn't seem anything out of the ordinary)
     
  10. Dekema2 macrumors 6502a

    Dekema2

    Joined:
    Jul 27, 2012
    Location:
    WNY or Utica
    #10
    Somehow I installed on an external Toshiba Canvio 1TB effortlessly. I even partitioned it in half and added Time Machine to the other.

    ----------

    Did you click to install on the external and not the internal SATA drive?
     

Share This Page