Problems installing Snow Leopard on brand new Intel 320 120GB SSD

Discussion in 'MacBook Pro' started by gguerini, May 4, 2011.

  1. gguerini macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #1
    I finally got my Intel 320 120GB SSD.

    Before I started the process, I backed up all my data. Removed my old HDD and put the new SSD inside of my Macbook Pro 13 (2010). Then I started the Snow Leopard installation process (from the DVD). The Disk Utility recognized my SSD perfectly, I erased (with zero out data) it and then the installation finally started.

    I was expecting to be a super fast process, or at least take the usual 30 minutes. Well, It started super slowly and now, 40 min later, I'm not even in the half. Actually, apparently it's not going further anymore.

    Should I stop the installation to try again? The bar is not moving for a while now.

    I'm so disappointed. I only chose this SSD because it should be reliable and that would be hassle-free with my Macbook Pro.

    What do you think I should do? Thanks so much.
    :mad:
     
  2. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #2
    So.. I started it over. Even in the beginning, the DVD stops making noise. And it's pretty much the same thing.... :(

    I dont know what to do?

    Did anybody have problems with the Intel 320 SSD?
     
  3. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #3
    mite be a borked install disk. SL installed fine on my 320.
     
  4. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #4
    Maybe, but I used this disc last week. Well, I will try my external DVD drive and another disc.

    Thanks!
     
  5. brentsg macrumors 68040

    Joined:
    Oct 15, 2008
    #5
    No trouble installing to an Intel 320 300GB here..
     
  6. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #6
    I managed to install Snow Leopard from an external drive successfully in the last try (the third, by the way). During the update, I opened Safari to download Google Chrome and when the flash video started playing (Chrome's website) I had my first Kernel Panic. I restarted the computer and started the update process again. Almost in the end of the process, my mac froze. I didn't get the "beach ball". It just froze. Then I went to bed.

    This morning I completed the update process, installed Office '11 and iLife '11. Everything went fine. I booted my mac and everything was ok.

    Then I ran the TRIM Enabler and when I booted again, the second Kernel Panic. Since then, everything is all right and my Mac is blazing fast. Incredible! The boot time is incredibly fast. I open all the apps of my mac in matters of seconds. Well, exactly what you expect from an SSD. :)

    ps: TRIM is now enable!

    The point is, I last night I upgraded my Mac with the new Intel 320 SSD, and I added more memory as well. I was using 6gb (2GB + 4GB), and now I removed the 2GB stick, and added another 4GB.
    I bought exactly the same brand, model.. I checked all the number, and it's the same memory. But, do you think it's the new memory stick that is causing the Kernel Panics?

    I remember reading about SSD problems related to the "beach ball" spinning, but not to Kernel Panics. Should I removed the new memory stick and do some tests?

    Thanks again guys!!
     
  7. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #7
    Memory could very easily be causing kernel panics. What do the panic logs say?
     
  8. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #8
    Where can I find the logs?
     
  9. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #9
    Log:


    Interval Since Last Panic Report: 1440 sec
    Panics Since Last Report: 1
    Anonymous UUID: 16FAA3F2-0B10-42F1-B187-245408B94BE7

    Thu May 5 10:53:21 2011
    panic(cpu 1 caller 0xffffff80002c4287): Releasing non-exclusive RW lock without a reader refcount!
    Backtrace (CPU 1), Frame : Return Address
    0xffffff80bddbb458 : 0xffffff8000204b99
    0xffffff80bddbb558 : 0xffffff80002c4287
    0xffffff80bddbb580 : 0xffffff800021507e
    0xffffff80bddbb690 : 0xffffff8000217ee9
    0xffffff80bddbb790 : 0xffffff8000218467
    0xffffff80bddbb7c0 : 0xffffff800021543a
    0xffffff80bddbb7f0 : 0xffffff800030d9fc
    0xffffff80bddbb8e0 : 0xffffff800030e2d5
    0xffffff80bddbb910 : 0xffffff800043dd0b
    0xffffff80bddbb930 : 0xffffff800044696a
    0xffffff80bddbb9c0 : 0xffffff8000431aa1
    0xffffff80bddbba60 : 0xffffff800030be5b
    0xffffff80bddbbad0 : 0xffffff80004726fb
    0xffffff80bddbbf40 : 0xffffff80004e52e7
    0xffffff80bddbbfa0 : 0xffffff80002e25c1

    BSD process name corresponding to current thread: iTunes

    Mac OS version:
    10J869

    Kernel version:
    Darwin Kernel Version 10.7.0: Sat Jan 29 15:16:10 PST 2011; root:xnu-1504.9.37~1/RELEASE_X86_64
    System model name: MacBookPro7,1 (Mac-F222BEC8)

    System uptime in nanoseconds: 84159450856
    unloaded kexts:
    (none)
    loaded kexts:
    com.vmware.kext.vmnet 3.1.2
    com.vmware.kext.vmioplug 3.1.2
    com.vmware.kext.vmci 3.1.2
    com.vmware.kext.vmx86 3.1.2
    com.apple.driver.AppleHWSensor 1.9.3d0 - last loaded 20741518650
    com.apple.filesystems.autofs 2.1.0
    com.apple.driver.AppleTyMCEDriver 1.0.2d2
    com.apple.driver.AGPM 100.12.19
    com.apple.driver.AudioAUUC 1.54
    com.apple.driver.AppleMikeyHIDDriver 1.2.0
    com.apple.driver.AppleUpstreamUserClient 3.5.4
    com.apple.driver.AppleIntelPenrynProfile 17
    com.apple.Dont_Steal_Mac_OS_X 7.0.0
    com.apple.driver.AppleMikeyDriver 1.9.9f12
    com.apple.driver.AppleHDA 1.9.9f12
    com.apple.driver.AppleMCCSControl 1.0.17
    com.apple.driver.AppleIntelNehalemProfile 11
    com.apple.driver.AudioIPCDriver 1.1.6
    com.apple.driver.AirPortBrcm43xx 423.91.27
    com.apple.driver.AppleGraphicsControl 2.8.68
    com.apple.driver.SMCMotionSensor 3.0.0d4
    com.apple.iokit.AppleBCM5701Ethernet 2.3.9b6
    com.apple.kext.AppleSMCLMU 1.5.0d3
    com.apple.driver.AppleIntelMeromProfile 19
    com.apple.driver.AirPortBrcm43224 427.36.9
    com.apple.driver.ACPI_SMC_PlatformPlugin 4.5.0d5
    com.apple.driver.AppleLPC 1.4.12
    com.apple.driver.AppleBacklight 170.0.34
    com.apple.GeForce 6.2.6
    com.apple.driver.AppleUSBTCButtons 200.3.2
    com.apple.driver.AppleIRController 303.8
    com.apple.driver.AppleUSBTCKeyEventDriver 200.3.2
    com.apple.driver.AppleUSBTCKeyboard 200.3.2
    com.apple.driver.AppleUSBCardReader 2.5.8
    com.apple.iokit.SCSITaskUserClient 2.6.5
    com.apple.iokit.IOAHCIBlockStorage 1.6.3
    com.apple.driver.AppleAHCIPort 2.1.5
    com.apple.BootCache 31
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
    com.apple.driver.AppleUSBHub 4.1.7
    com.apple.driver.AppleFWOHCI 4.7.1
    com.apple.driver.AppleUSBEHCI 4.1.8
    com.apple.driver.AppleEFINVRAM 1.4.0
    com.apple.driver.AppleRTC 1.3.1
    com.apple.driver.AppleUSBOHCI 4.1.5
    com.apple.driver.AppleHPET 1.5
    com.apple.driver.AppleSmartBatteryManager 160.0.0
    com.apple.driver.AppleACPIButtons 1.3.5
    com.apple.driver.AppleSMBIOS 1.6
    com.apple.driver.AppleACPIEC 1.3.5
    com.apple.driver.AppleAPIC 1.4
    com.apple.driver.AppleIntelCPUPowerManagementClient 105.13.0
    com.apple.security.sandbox 1
    com.apple.security.quarantine 0
    com.apple.nke.applicationfirewall 2.1.11
    com.apple.driver.AppleIntelCPUPowerManagement 105.13.0
    com.apple.driver.AppleProfileReadCounterAction 17
    com.apple.driver.AppleProfileTimestampAction 10
    com.apple.driver.AppleProfileThreadInfoAction 14
    com.apple.driver.AppleProfileRegisterStateAction 10
    com.apple.driver.AppleProfileKEventAction 10
    com.apple.driver.AppleProfileCallstackAction 20
    com.apple.iokit.IOSurface 74.2
    com.apple.driver.AppleHDAPlatformDriver 1.9.9f12
    com.apple.iokit.IOBluetoothSerialManager 2.4.0f1
    com.apple.iokit.IOSerialFamily 10.0.3
    com.apple.driver.AppleHDAHardwareConfigDriver 1.9.9f12
    com.apple.driver.DspFuncLib 1.9.9f12
    com.apple.iokit.IOAudioFamily 1.8.0fc1
    com.apple.kext.OSvKernDSPLib 1.3
    com.apple.driver.AppleSMBusController 1.0.8d0
    com.apple.driver.AppleHDAController 1.9.9f12
    com.apple.iokit.IOHDAFamily 1.9.9f12
    com.apple.nvidia.nv50hal 6.2.6
    com.apple.iokit.IOFireWireIP 2.0.3
    com.apple.iokit.AppleProfileFamily 41
    com.apple.iokit.IO80211Family 314.1.1
    com.apple.iokit.IONetworkingFamily 1.10
    com.apple.driver.NVSMU 2.2.7
    com.apple.driver.AppleSMC 3.1.0d3
    com.apple.driver.IOPlatformPluginFamily 4.5.0d5
    com.apple.driver.AppleSMBusPCI 1.0.8d0
    com.apple.NVDAResman 6.2.6
    com.apple.iokit.IONDRVSupport 2.2
    com.apple.iokit.IOGraphicsFamily 2.2
    com.apple.driver.BroadcomUSBBluetoothHCIController 2.4.0f1
    com.apple.driver.AppleUSBBluetoothHCIController 2.4.0f1
    com.apple.iokit.IOBluetoothFamily 2.4.0f1
    com.apple.driver.AppleUSBMultitouch 206.6
    com.apple.iokit.IOUSBHIDDriver 4.1.5
    com.apple.iokit.IOUSBMassStorageClass 2.6.5
    com.apple.iokit.IOSCSIBlockCommandsDevice 2.6.5
    com.apple.iokit.IOSCSIMultimediaCommandsDevice 2.6.5
    com.apple.iokit.IOBDStorageFamily 1.6
    com.apple.iokit.IODVDStorageFamily 1.6
    com.apple.iokit.IOCDStorageFamily 1.6
    com.apple.driver.AppleUSBMergeNub 4.1.8
    com.apple.driver.AppleUSBComposite 3.9.0
    com.apple.driver.XsanFilter 402.1
    com.apple.iokit.IOAHCISerialATAPI 1.2.5
    com.apple.iokit.IOSCSIArchitectureModelFamily 2.6.5
    com.apple.iokit.IOAHCIFamily 2.0.5
    com.apple.driver.AppleFileSystemDriver 2.0
    com.apple.iokit.IOUSBUserClient 4.1.5
    com.apple.iokit.IOFireWireFamily 4.2.6
    com.apple.driver.AppleEFIRuntime 1.4.0
    com.apple.iokit.IOUSBFamily 4.1.8
    com.apple.driver.AppleMCP89RootPortPM 1.11
    com.apple.iokit.IOHIDFamily 1.6.5
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.security.TMSafetyNet 6
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.driver.DiskImages 289
    com.apple.iokit.IOStorageFamily 1.6.2
    com.apple.driver.AppleACPIPlatform 1.3.5
    com.apple.iokit.IOPCIFamily 2.6
    com.apple.iokit.IOACPIFamily 1.3.0
    Model: MacBookPro7,1, BootROM MBP71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 8 GB, SMC 1.62f6
    Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
    Memory Module: global_name
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.131.36.9)
    Bluetooth: Version 2.4.0f1, 2 service, 19 devices, 1 incoming serial ports
    Serial ATA Device: INTEL SSDSA2CW120G3, 111.79 GB
    Serial ATA Device: MATSHITADVD-R UJ-898
    USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8507, 0x24600000
    USB Device: Internal Memory Card Reader, 0x05ac (Apple Inc.), 0x8403, 0x26100000
    USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06600000
    USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8213, 0x06610000
    USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x06500000
    USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0236, 0x06300000
     
  10. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
  11. altecXP macrumors 65816

    Joined:
    Aug 3, 2009
    #11
    Why would you Zero out a SSD? that just causes extra wear. Not to mention there is no need to erase an already blank drive.
     
  12. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #12
  13. gotclawed macrumors newbie

    Joined:
    Oct 25, 2010
    #13
    Hey, sorry to hear your having problems with the install. I just installed the Intel 320 120gb in a mid '09 13"MBP, and this is my story... Backed up old drive to an external, fitted new drive, then reinstalled via the SL disk. This is were I got nervous as it took ages. From reading others experiences I was expected to be up and running within an hour. All in all it took almost 3 hours to install the OS and use migration assistant to copy apps etc (this amounted to no more than 20gb).
    I was convinced I'd either got a lemon or made lemonade. At the one hour mark I figured it would be best to just leave it alone, suffer the withdrawal symptoms and pray that the dvd drive would show some sign of life. Eventually after the longest hang ever, the end was in site.
    I suppose all I can say to you is to hold in there for a while, be patient and watch the magic unfold!!
    Good luck.
     
  14. JonasFalslev macrumors newbie

    Joined:
    May 4, 2011
    #14
    Sounds strange.. I have the Intel 320, 120GB. I installed the OS in about 20 minutes. I had a TM back-up and that progress took about 15 minutes. Overall my SSD have performed over all expectation, my boot time after the recent update is 8-9 seconds.
     
  15. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #15
    So guys, the installation problem is over I guess. My real problem now is the once a day Kernel Panic, but I think it's due to my new memory stick. Tonight I will remove the new memory stick and put the old one. If it doesn't happen another Kernel Panic, I try to return my memory stick and I'll know for sure that the problem is not the SSD!

    Thank you guys for your support!!!

    I will let you know what going on.
     
  16. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #16
    If you have/had bad memory and installed the OS, you'll need to get rid of the bad RAM and reinstall to be sure, as you could have a corrupt OS.
     
  17. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #17
    So here we go again.

    Today I ran a memory test (Rember app) and it turned out be a faulty stick, the new one I had just put in. Knowing that I removed the faulty memory and went back to the original memory set, that was 4GB (GSKILL) + 2GB (original). I ran the memory test again and it worked great!

    So I thought I had found the problem. I kept using the machine and it seemed very stable, but when I tried to turn off my machine, another Kernel Panic. I tried to reset the PRAM and SMC again because of the "new" memory set, then I turned on again and left my computer playing a movie. When I got home, another Kernel Panic! :(

    Kernel Panic Details:

    Interval Since Last Panic Report: 25509 sec
    Panics Since Last Report: 5
    Anonymous UUID: 16FAA3F2-0B10-42F1-B187-245408B94BE7

    Sat May 7 19:47:12 2011
    panic(cpu 1 caller 0xffffff80002cffca): Kernel trap at 0xffffff7f807f70a6, type 14=page fault, registers.

    Kernel Extensions in backtrace (with dependencies):
    com.apple.nvidia.nv50hal(6.2.6)@0xffffff7f81400000->0xffffff7f81803fff
    dependency: com.apple.NVDAResman(6.2.6)@0xffffff7f80664000
    com.apple.NVDAResman(6.2.6)@0xffffff7f80664000->0xffffff7f80932fff
    dependency: com.apple.iokit.IOPCIFamily(2.6)@0xffffff7f8061d000
    dependency: com.apple.iokit.IONDRVSupport(2.2)@0xffffff7f80656000
    dependency: com.apple.iokit.IOGraphicsFamily(2.2)@0xffffff7f8062f000


    This one is clearly related to the graphic card, but I don't think this is my problem.

    I don't know what else to do. I still don't think the my problem is the SSD but it's not the memory as well, and my machine was working great before I started using the SSD and the new memory stick.

    Do you guys think I should try to reinstall the MacOS? Or try something more drastic and put my old HDD and see how it goes?

    Thanks again!
     
  18. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #18
    I would reinstall the OS. Having bad memory during the orig install may have caused a corrupted file.
     
  19. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #19

    I think this is my last resort right? I will try to do that tonight and I will keep you guys updated. Thanks again!!
     
  20. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #20
    Yes.

    Also, if you ran Rember in the GUI and it caught the bad RAM, it must have been really really bad. If it's running in the GUI, it can't test any of the RAM the rest of the OS is taking up. Put Rember in your /Applications folder, boot into single-user mode, then run this to be sure:

    /Applications/Rember.app/Contents/Resources/memtest all 5

    That will test more of your memory five times. If you get through that, you're probably fine on RAM. Then reinstall.

    Note: you can also put the other RAM back in and retest. Sometimes it's just a bad connection.
     
  21. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #21
    Detrius, I strongly believe my media (Snow Leopard) has problems. I tried many times to create an image from the DVD to install using my FireWire external hard-drive but it doesn't work. I gave up, and I ended up using the DVD. It didn't work! Right in the beginning of the installation I got a yellow question mark saying that something went wrong!

    Tonight I will try with a different DVD. The retail version.

    Wish me luck! :(
     
  22. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #22
    That's not a good sign either. Yes, hopefully another disc will work properly.
     
  23. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #23
    Hello Detrius, as you said, it wasn't a good sign at all. I tried to install with a retail version of SL using an external DVD drive. Same error! In the beginning of the installation I got a yellow question mark saying that it couldn't copy the necessary files.

    Before that, I put the original 4GB memory set (2x 2GB) and the original HDD (Scorpio Blue 500GB) and everything was working properly without Kenel Panics. Now I'm (almost) pretty sure the problem is the SSD.

    The funny thing is I erased the SSD without problems, I erased the SSD with ZERO OUT data without problems. I "verified" the SSD using Disk Utility without problems. If my SSD was faulty, how would I be able to know? Is there a HDD/SSD test tool, like the Memtest for memories?

    Tonight I will try the last thing. I will put the original 260GB HDD that came with my Macbook Pro and try to install Snow Leopard. It it works, I will clone this drive and try to transfer to the SSD. Lets see..

    If it doesn't work, I will send it back to Intel. :( This is very disappointing. Specially when I realize that my macbook pro is super slow (after using the SSD for few hours).

    Any other thoughts?
     
  24. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #24
    Maybe I missed the post, but did you try using in the original Apple OEM RAM w/ the SSD? You said you put in GSKILL brand. From my own Mac experience, Macs are extremely particular about RAM. I've been burned too many times and now only use Crucial (Micron), Kingston (main brand, not ValuRAM), or OWC. Anything else is a riverboat gamble.

    By gamble I mean that even if one stick of GSKILL works, no guarantee a 2nd stick will, esp. if the chips on that stick are from a different lot or source.
     
  25. gguerini thread starter macrumors regular

    gguerini

    Joined:
    Jun 28, 2007
    #25
    Apparently my problem is not memory, but I will explain it briefly: I was using the combination of 2GB (original) + 4GB (GSKILL) without any problem for 10 months. Last week I bought exactly the same memory stick from GSKILL (4g) and the Intel 320 120GB SSD. I upgraded my Macbook and since then I've been having Kernel Panic. At first I thought it was the memory, so I removed the new 4GB stick and put the 2GB back. It didn't work. Last night I removed the other 4GB (the old one), going back then to the original memory set 2GB + 2GB. It didn't work. I can't install Snow Leopard on my Intel 320 SSD. That's it!
     

Share This Page