Resolved Problems Installing Windows x64 on Mac Pro 1,1

Discussion in 'Mac Pro' started by appleguy010, Mar 3, 2016.

  1. appleguy010 macrumors newbie

    Joined:
    Mar 3, 2016
    #1
    So Here's my situation: I have tried for a while to install Windows 7 64 bit on my Mac Pro 1 1 machine. First I just burned the .iso file to a DVD and tried booting of it. And of course I get the message:
    1

    2
    Select CD Rom Boot type

    So after searching far and wide on the interwebs I made a new .iso file using the jowie method here: http://www.jowie.com/select-cd-rom-boot-type
    Making the new iso went smoothly and I burned the new one to the disk. And now when I boot of the DVD I get the message: Cannot Boot from CD: Error Code 5
    So of course I get started googling things and trying different things from different places. After rewriting the .iso again and burning that to a dvd I get a different message: Cannot find NTLDR
    At this point I got frustrated and gave up.
    A while later I started at it again because I new other people have persuaded Windows 64 bit onto this machine. After all getting El Capitan on the Mac Pro 1,1 is easy enough.
    So I found this video:
    I used a Windows 32 bit disk to boot the system as the Mac Pro 1,1 boots 32 bit windows just fine. And as later as seen in the video exchanged it for the Windows 64 bit disk and ran setup from the command prompt. The problem is that I get the message when trying to install: A required CD/DVD driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.
    As I understand it, it is because of my SATA drives not being recognized and that the solution is to get the SATA drivers for the Motherboard. I don't get this message on the 32 bit disk. And I tried googling for the answer for the problem but didn't find anything applicable too my situation. I tried looking through Apple's Boot Camp drivers and selecting all the SATA drivers that I can find but it still doesn't work. Is there anyplace where I can get the drivers for the system? Does the method I'm currently trying not work? Should I use a different method to install?

    Thanks,
    Joshua
     
  2. cw48494 macrumors regular

    cw48494

    Joined:
    Jun 17, 2015
    #2
    Install Windows destination disk into tray 1 and eject all other drives, try again.
     
  3. appleguy010 thread starter macrumors newbie

    Joined:
    Mar 3, 2016
    #3
    Nope didn't work I still get the same driver error
     
  4. appleguy010 thread starter macrumors newbie

    Joined:
    Mar 3, 2016
    #4
    Ok so I installed Windows 64 bit to my boot camp drive using VMware Fusion. It boots in fusion fine, but when I try to boot the machine off the drive it freezes while booting and the system reboots.
    --- Post Merged, Mar 3, 2016 ---
    Oh and my specs are: Intel Xeon x5355 8 core, 11 GB of ram(4x2gb 2x1gb 2x512mb), ATI Radeon HD 5770 Graphics.
     
  5. appleguy010 thread starter macrumors newbie

    Joined:
    Mar 3, 2016
    #5
    Here's a picture in Windows recovery:
    image.jpeg
     
  6. owbp macrumors 6502a

    owbp

    Joined:
    Jan 28, 2016
    Location:
    Belgrade, Serbia
    #6
    Hey @appleguy010, after you followed through that first link in your OP, you need to do this with your installer prior to burning it to DVD. Then remove all drives except the one you're installing Windows to and you should be fine.
    Remember to eject DVD on the first reboot during installation, because it has tendency to get stuck afterwards on "Completing installation" if you don't.

    That did it for me on my MP1,1 and i updated it to Win10 just like you would update any Windows PC (but ill get back to 7 almost certainly... 10 still feels like public beta IMO).
     
  7. appleguy010 thread starter macrumors newbie

    Joined:
    Mar 3, 2016
    #7
    Cool I'll try this tomorrow. I actually got Windows 7 64 bit installed to the drive through VMware but it wouldn't boot outside virtual machines.
     
  8. owbp macrumors 6502a

    owbp

    Joined:
    Jan 28, 2016
    Location:
    Belgrade, Serbia
    #8
    Give us shout out how it went. I think i remembered everything that needs to be done.

    1st, i had error like yours so i followed the same link you did;
    2nd, i had another error (don't remember exactly what it was) so i googled the link i left you;
    3rd, i booted into installation, but couldn't move on after partition/format screen - removed all drives for fix;
    4th, upon first reboot installer got stuck on "completing installation" forever - eject DVD after first reboot for fix.

    I really don't think i did anything else, so you shouldn't have any problems (fingers crossed)!

    P.S. Install bootcamp drivers afterwards if you don't want any "unknown devices" and option to boot directly to OS X from Win. You'll have to go into bootcamp install folder and run setup 64bit manually from Win because it won't run on "32 bit" machine... :)

    Also, on C:/Windows/System32/drivers i renamed AppleHFS.sys and AppleMNT.sys drivers (so they won't load) because I've read that they tend to bring up "blues screen of death" on Win boot... Don't know if it still does or not, haven't test it myself.
    Screen Shot 2016-03-04 at 6.40.48 AM.png
     
  9. appleguy010, Mar 4, 2016
    Last edited: Mar 4, 2016

    appleguy010 thread starter macrumors newbie

    Joined:
    Mar 3, 2016
    #9
    It worked!!
    Thank you so much!
    I spent hours looking for a solution.
    I made a new .iso using Jowie's method, followed the instructions in the link you provided, removed all drives except bay 1, installed Windows, then I installed the boot camp drivers via command prompt.
    Thank you so much for the help!
    Now I have more than 2 gigs of ram in Windows.

    [Solved]

    UPDATE: I also had issues connecting to the internet after installing the Boot Camp drivers. To fix I went to Administrative Tools, Computer Management, Device Manager, Network Adapters, right clicked 802.11n network adapter, Properties, Driver tab, Roll Back Driver.
     

Share This Page