Problems making cellular calls from Yosemite

Discussion in 'OS X Yosemite (10.10)' started by Sir Ruben, Oct 22, 2014.

  1. Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #1
    Bit of a strange issue, but within the FaceTime preferences on Yosemite I have the option ticked for 'Use your phones cellular connection to make and receive calls when your iPhone is nearby and on wi-fi'. When I tried to place a call it told me that the relevant setting wasn't configured on my iPhone.

    So, on my iPhone in Settings > FaceTime > i switched on 'iPhone Mobile Calls' however this keeps switching itself off again (tells me I need to be signed into the same iCloud account which I am) unless I also have an email address ticked as well as my phone number. So ticking an email address and then the same email address in Yosemite allow the setting to stay on and it works fine.

    Upon unticking the email address the 'iPhone Mobile Calls' setting turns itself back off.

    Its a little thing but its really annoying. Anyone know how to resolve?
     
  2. Allograft macrumors regular

    Joined:
    Oct 19, 2014
    #2
    Interesting, I have a slightly different issue with my iPhone 5S on 8.1 and mid-2014 rMBP on 10.10. All Handoff features work well with the exception of phone call continuity. Works only intermittently and actually very infrequently. When the phone number is called, Continuity doesn't pick it up and when I try to initiate calls from the rMBP, it fails saying that the devices have to be on the same network, which they are.

    I tried switching from the phone number in the second field to having the caller ID as the email like you mentioned, but I still have the same issue for me
     
  3. Allograft macrumors regular

    Joined:
    Oct 19, 2014
    #3
    I have an additional detail to add here. My issue is solved.

    -equipment mid-2014 base 15" rMBP and iPhone 5S. Wireless router Asus RT-AC87U
    -clean installs of both 10.10 and iOS 8.1. 10.10 from the bootable drive and 8.1 from DFU mode.
    -logging out of all iCloud and logging back in in iCloud, iMessage, and FaceTime all using the same email. I had used my @me email at one point by the FaceTime on iP5S showed as 3rd party email log in that Apple likes. So, all logged in under the 3rd party email.
    -all settings in MBP and iP5S for handoff and continuity
    -FINALLY ******wifi band******* this was my ultimate issue. It has already been identified that Continuity doesn't work when PC is on ethernet and iPhone is on Wifi even if on the same router...well, ALSO LOOK OUT FOR MIXED ENVIRONMENT WIFI. I have my router set up so that 2.4 and 5 ghz broadcast the same SSID and the devices switch back and forth based on best signal. This is a problem for continuity. When I forced both devices on the same band, everything was seamless. Problem seems to be that rMBP can pick up and hold onto 5 ghz from my desk whereas iP5S can only get 2.4 at the same location. Watch out for what band you're on! Application handoff works okay across multi band environments, phone handoffs, no. at least not consistently.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    You have to have FaceTime on the Mac using the same account details as on the iPhone, it sounds like you have FaceTime on the Mac set to use the email address?

    I have both the AppleID email address and the cellular number selected in both the Mac and iPhone FaceTime settings and it works for me, I'm not sure what I'd be resolving to try and work without one of the methods configured??
     
  5. whackmack168 macrumors newbie

    Joined:
    Oct 22, 2014
    #5
    It only works on my early 2011 MPB and iphone 5 when I have at least 1 email selected in FaceTime settings on the phone and computer along with my cell number. I selected the email that I use to log into icloud, itunes, app store, etc. I believe that you have to keep it enabled too.
     

Share This Page