Problems Networking MacBook Pro & WinXP

Discussion in 'MacBook Pro' started by jesseneufeld, Dec 9, 2008.

  1. jesseneufeld macrumors newbie

    Joined:
    Dec 3, 2008
    #1
    Hi,

    I've got a MacBook Pro running OS X 10.4.11
    I recently had to reinstall the operating system and now I can't get my file sharing network to work.
    I am trying to connect to a PC running Windows XP.
    My router is a SpeedStream 6530.

    I have enabled Windows Sharing as well as Personal File Sharing.
    I have created a network on the PC called "Mynetwork".
    I have turned off my firewall.
    Still the pc does not appear in my network tab.
    I tried to "connect to server" using smb://"ip address"/"user name"
    and all I get is "Could not connect to the server because the name or password is not correct."

    What am I doing wrong? This used to work before!
    Please help!
     
  2. macrem macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    #2
    Can you also ping the Windows IP from your MBP & vica versa? Maybe your Windows machine refuses to communicate with your MBP unless you set the proper Workgroup and/or Domain in your MBP's network device settings under WINS.

    Anecdotal: I configured a Linux machine to be a samba server which could be accessed by Macs and Windows machines. I had to keep messing around with smb.conf until finally Windows acknowledged the server. After each change, the Mac always recognized the the Samba server. Now I have no Windows machines and use a much more secure, encrypted protocol that was so simple to configure. Microsoft made such a finicky protocol, but it's insecure so I don't see the point besides trying to discourage using other OSes.
     
  3. jesseneufeld thread starter macrumors newbie

    Joined:
    Dec 3, 2008
    #3
    Each machine can ping the other. That's why I find this so confusing!
    I need to play around with the workgroup settings a bit more, I guess. I read in another post that another user's mac wouldn't recognize the pc unless it was in the default group Mshome. My workgroup was originally called Mshome, but I renamed when it wasn't working. I'll have to try again.

    If you have any suggestions, please let me know. I'm currently using a flashdrive to transfer data, and it's quite time consuming!
     
  4. macrem macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    #4
    Aside from the workgroup, you might also be missing this?:
    Also, try putting the Windows share in place of the "user name":

    smb://"ip address"/"windows share"

    ...otherwise combing through the aforementioned thread will probably get it working.
     

Share This Page