Problems printing since Upgrading to Snow Leopard

Discussion in 'macOS' started by treehorn, Sep 3, 2009.

  1. treehorn macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #1
    Before I call Apple I figured I'd see if anybody here has any ideas.

    I have an Epson Stylus Photo R260 and ever since I updated to Snow Leopard I haven't been able to use it. It's usually hooked up to my Airport Extreme Base Station and I've never had a problem.

    Now I only get "Connected to Main-Base Local...." message. Doing a Network Diagnostic says "you appear to have a working internet connection but cannot find "Epson Airport._riusbprint._tcp.local."

    I've deleted/reset all printer settings. I've had the computer discover the printer and set it up automatically. I've reset my Airport express.

    Thing that makes me wonder if it's Snow Leopard issue is that I've tried to print directly from the computer/usb and had no luck (on that I get "Sending Print Data" that goes on forever until I delete it)
     
  2. MRFMN macrumors newbie

    Joined:
    Sep 3, 2009
    Location:
    Philly
    #3
    Printing still a problem after update

    Good day,

    Not sure how many of us there are.

    But the 10.5.8 update also made it impossible for me to print wirelessly. When I connect the printer directly to my IMac, it is fine. When I connect to Airport Extreme, so my wife can also print, I no longer can. It says I am offline and does not recognize my printer.

    Because I initially thought I had an Adobe problem, this printing problem took me all day yesterday and many hours today to get back to where I am now.

    First time in all the years I've had Macs that the update was a problem. But it's been a time-consuming one.
     
  3. treehorn thread starter macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #4
    Annoying thing is that the printer is on the list of ones supported by SL...
     
  4. jjk454ss macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #5
    My HP 2600n worked fine after an upgrade, but then after a clean install I had to get the drivers from HP. Before I never had to do this, but I though this was on purpose. Rather than have all these drivers in there you will never use, Snow Leopard doesn't install them automatically.

    Do you just need to get the drivers installed from the manufacturer?
     
  5. treehorn thread starter macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #6
    So I fixed the problem via a two pronged attack.

    1) Downloaded and installed drivers from Epson.com

    2) Downloaded the newest version of Gutenberg Drivers at http://gimp-print.sourceforge.net/MacOSX.php (the newest version is Gutenprint 5.2.4 and the ones installed with SL are 5.2.3)

    Not sure which fixed it but...(the big problem apparently was that the printer utility that SL wanted to use didn't do crap...wouldn't let me know that a cartridge was out, which apparently was the thing that was tying up the printing)
     
  6. Schtibbie macrumors 6502

    Joined:
    Jan 13, 2007
    #7

    Same problem here. Leopard printed fine on my HP Photosmart 7960 printer but Snow Leopard first of all thought it was a 6000-series and wouldn't print, THEN when I re-added it as a 7900-series, it spends a LONG LONG time on "Sending Print Data" while nothing happens before finally it spits out one stinkin' page.

    Not lovin' it. Hoping for better drivers at some point. Yes, I already got the 10.6.1.
     

Share This Page