Problems printing with Canon MX860 since installing Lion

Discussion in 'Mac OS X Lion (10.7)' started by ggalanti, Aug 15, 2011.

  1. ggalanti macrumors newbie

    Joined:
    Aug 15, 2011
    #1
    Ever since I installed OS X Lion, I've been having problems printing with my Canon Pixma 860. Sometimesw it works just fine. Other times, I get a "communication error." I downloaded the latest drivers from Canon, I have deleted and reinstalled the printer in my system preferences, and I've disconnected and replugged in the printer. Sometimes these actions work, sometimes they don't. It will print one or two documents just fine, and then when I try to print the next document moments later, I get a communication error. I use the printer wirelessly; I tried connecting a USB cable, but it didn't help. My husband, who is using Snow Leopard on his iMac and also connects to the printer wirelessly, is having the same exact problems from his computer. It's driving me nuts. Is anyone else having the same problem? Is there a fix, other than buying a new printer?
     
  2. senseless macrumors 68000

    senseless

    Joined:
    Apr 23, 2008
    Location:
    Pennsylvania, USA
    #2
    I have had problems with my multifunction Canon laserprinter after the last lion update. Reinstalling the interim Lion driver doesn't help and the new drivers aren't due until October. I think the error is unsupported printer or something along those lines.
     
  3. spress macrumors newbie

    Joined:
    Sep 7, 2011
    #3
    Canon MX 860

    It took me an hour to find the Canon IJ network utility. Once downloaded & installed, connecting printer to network was a breeze, & it only took a couple of minutes.
     

Share This Page