Problems removing Aluminum iMac RAM

Discussion in 'iMac' started by 300ZX, Sep 29, 2007.

  1. 300ZX macrumors member

    Joined:
    Oct 13, 2005
    #1
    I bought another 1GB stick to put in it the other day. I followed the directions, but I had some troubles. It said to "insert and push up". I figured this would just be like a laptop and it would click no problem.

    I pushed it in and could feel it start to seat, so I assumed I needed to seat it, then push it up. The RAM completely seated, but I never heard a click. I pushed pretty hard trying to get it to click, then again to verify it went in all the way.

    I was unable to get the RAM to eject by pulling on the tab. Everything I've been reading says the RAM will just jump out; however, mine is completely stuck. This isn't a HUGE deal, since OS X recognizes the RAM and the computer works fine. I am just a little curious as to why it got stuck in there.

    ANYONE else have this problem or have any suggestions?

    EDIT: Seems I'm not the only one with this problem - http://www.youtube.com/watch?v=glki-cEICpo
     
  2. imacan macrumors regular

    Joined:
    Jan 14, 2007
    Location:
    Montreal, Canada
    #2
    It was very hard to get the memory out for me too (almost gave up) until I tried not pulling on the tab straight but by wiggling it (pulling left wright left wright ...), it then came out easily. I don't know if it's the solution for everyone though.
     
  3. Luap macrumors 65816

    Luap

    Joined:
    Jul 5, 2004
    #3
    Same here.. I did the same thing. The tabs dont seem to work at all. But some gentle wiggling got it out ok.
     
  4. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #4
    Don't use tools on the RAM, you will damage it and void the warranty.
    There seems to be a known problem with some iMac and MacBook sockets. In addition, the third-party RAM may be marginally thicker than Apple's, and therefore tighter.

    Take it to an Apple service provider if you need to get it extracted and can't with finger power alone.
     
  5. Italchef macrumors 6502

    Joined:
    Nov 3, 2003
    Location:
    Maple, Ontario
    #5
    I just pulled the tab on the original RAM and it popped out onto my lap. The new RAM I pushed straight in with a thumb on each end. I didn't push up or anything and didn't feel a click. The computer recognizes the RAM but is it possible that its not seated properly?

    Mick
     
  6. CashGap macrumors 6502

    CashGap

    Joined:
    Sep 15, 2007
    Location:
    Music City, USA
    #6
    Push in on the ram a little. Then pull.

    Worked for me...
     
  7. Trent Batson macrumors newbie

    Joined:
    Feb 16, 2012
    #7
    How I got the RAM out of iMac 21.5 " 4 slots

    The RAM is hard to get out -- pulling the tabs "gently" does not work. The chip is lodged in a multi-pin port, so can get stuck; the port, or slot, has a tight grip (as it should). If you are replacing the RAM in the machine, you will be throwing out your old chips anyway, so I just used a screwdriver to jostle the chip and then it came out of its slot. No damage from pushing on each side of the chip to loosen it. Putting in the new memory was just as hard -- I have four slots, and four memory chips. I was afraid I would puncture my thumbs I had to push so hard to get the new chips in. Conclusion: the grip in the memory slot is so tight that it is hard to get old chips out and equally hard to get them in.

    Once I had jostled the old chips, the tabs did work to pull them out. My screwdriver method took 3 minutes, not 30. The YouTube video included in this thread featured using a screwdriver to loosen the chips. I followed that advice.

    Cheers
    Trent
     
  8. Stan Mikulenka macrumors 6502

    Joined:
    Nov 20, 2009
    Location:
    Calgary, Canada
    #8
    Hi Trent,
    I hope you know you posted on 5 years OLD post...
     
  9. chomputer macrumors newbie

    Joined:
    Nov 6, 2013
    #9
    Stan,

    I hope you realize that this is nearly 2014 and still relevant today. Your comment offered no help when clearly there are plenty of frustrated people upgrading memory on various iMacs still in use.

    Apple hardware tends to last for many years with what purports to be a simple upgrade. This is not always the case now is it?!

    Carry on old chap and stay off my lawn.
     

Share This Page