Problems running application on iPod touch :(

Discussion in 'iOS Programming' started by Ron C, Jul 22, 2008.

  1. Ron C macrumors member

    Jul 18, 2008
    Ok, I've scoured the forum prior to posting this thread and while I may have missed it, here's what I'm seeing.

    I have created a development profile, all my certificates, an AppID, and have registered my iPod touch. Because it was on OS 1.x, I paid the $10 (+ tax :() for the 2.0 upgrade and have re-registered it in Xcode and done all that.

    I took one of the sample applications (BubbleLevel) and have set it up with Active SDK=Device-iPhoneOS2.0, Active Config=Debug. When I download it to the device, it says:

    "Your mobile device has encountered an unexpected error (0xE8000001) during the install phase: Verifying application.

    Try disconnecting and powering off the device; then power the device on and reconnect it."

    I'm not sure what an E8000001 is, but it smells like a certificate problem - it gets all the files to the device OK (I see the copying described) but when it checks on the device it's not happy.

    Any specific thoughts?

    Attached Files:

  2. grimjim macrumors member

    May 24, 2003
    I had this problem on my iPhone a lot after I upgraded to one of the later betas. I fixed it by synching, re-installing the 2.0 firmware and synching again.
    It's tedious, but it might be worth a try.

    Also, you may find this thread useful.
  3. Ron C thread starter macrumors member

    Jul 18, 2008
    It works now, but I'm not completely sure why...

    I managed to get it to work. I tried a multitude of things, but this one worked and the other one didn't.

    Here are some environment changes that didn't pertain directly to my application but seemed to matter:

    • Only 1 profile on the device at a time. This does seem important.
    • AppID has a name (why can't I delete AppIDs?) and only * for the bundle identifier (this allows ANY application name in a project to work. Convenient for development but invalid for distribution. I'm not there yet but someone probably is).
    • Create/Modify, download, and install a development profile that includes this new AppID. Before installing, make sure that the device doesn't have any other development profiles (this is easy for me, I'm only just starting, but it may be more difficult for others) and QUIT Xcode. The former seems to matter, but the latter definitely does. When Xcode is no longer running copy/move the downloaded file to ~/Library/MobileDevice/Provisioning Profiles. There should NOT be any other development profiles there either, though I can't tell if this is important either :(
    • Sync w/iTunes and restore via Xcode's Organizer window

    For the specific application I'm building (remember, I just downloaded the sample Bubble Level application, so it's not as if I actually did anything interesting)

    • In the project info set the "Code Signing Identity" to "iPhone Developer: <firstName> <lastName>" (this matches the key name in Keychain, so set it to whatever that is. Mine is "iPhone Developer: Ron C...")
    • In the project info set the "Code Signing Provisioning Profile" to "Default..." (again, this one worked while others didn't)
    • The directory in which the project is stored is the same name as the project name (warning: I don't know if this matters, I just did it and now it works).
    • Start with clean builds if you tinker with the certificates. It just seems to reduce opportunities for failure.

    One other thing that probably had something to do with it being successful was that I didn't change any of the properties of the executable. I'm going to try again and change the "Identifier" listed in the application properties (visible when you double-click the application, Targets->BubbleLevel in this case, and choose the Properties tab) - from it's current value of "com.yourcompany.$(PRODUCT_NAME:identifier)" to "com.ronc.$(PRODUCT_NAME:identifier)" and I'll post another follow-up whether that works or not.

    I do appreciate the help.

    Ron C
  4. Ron C thread starter macrumors member

    Jul 18, 2008
    That worked fine too, so now I'm going to try it again with another Sample application...
  5. Ron C thread starter macrumors member

    Jul 18, 2008
    Enough already :)

    I think I've gotten it licked, thanks everyone for the suggestions. I downloaded the code for a second sample application, TableSearch, made the changes to the Build configuration at the project level (set the Code Signing Identity and Code Signing Provisioning Profile) then "Build and Run" and :D voila, it downloaded and ran

    But I was wrong on one front - you can have more than one application downloaded using the development profile as long as the AppID matches, and since the AppID is *, everything matches.

    I'm done here, but that's for letting me vent ;)
  6. MacBuddySupport macrumors member


    Nov 19, 2007

    I have done all of these steps. I really need a video tutorial on how to setup the project and the portal.

    Please create a screencast.....
  7. bullride macrumors newbie

    Aug 9, 2008
    same for me

    are you supposed to pay the 99$ in order to test the application on the iphone. I have to admit when i signed up i did not even have a mac. now i have one, wrote the first app wanted to test on the iphone but got exactly the same message described above.

    I have downloaded sdk for free and are not quite sure if i did get a certificate by mail at all.

    please advice
  8. MacBuddySupport macrumors member


    Nov 19, 2007

    Yes, you do need to pay for the agreement. It's the only way to do it. Thats what I have heard. Also that error message means a memory failure on your iphone. I get it to. Apple tells me it something to do with the bundle name. Its not though

    Any suggestions from anyone???

Share This Page