Problems saving to flash drive from any microsoft office programs

Discussion in 'Mac Basics and Help' started by bkkusc, Oct 25, 2013.

  1. bkkusc, Oct 25, 2013
    Last edited: Oct 25, 2013

    bkkusc macrumors newbie

    Joined:
    Oct 25, 2013
    #1
    I have a somewhat strange issue with my MBP. Recently, about a week ago, I started having problems saving files from Word, Excel, and Powerpoint onto a flash drive.

    In Word I get the following message: Word cannot save or create this file. The disk my be full or write-protected. Try one or more of the following: etc.

    In Excel: Microsoft Excel cannot access the file. There are several possible reasons: The file name or path name does not exist. The file you're trying to open is being used by another program. The name of the workbook you're trying to save is the same as the name of another document that is read only.

    In Powerpoint: You don't have the permissions necessary to perform the operation. Use the finder to see if you have access privileges to the file or folder and that the file is not encrypted. If you don't have the privileges you want, contact an administrator for your computer or the owner of the file or folder.


    This happens no matter if it is a file from a year ago or a new blank document. I've tried with 4 different flash drives and they all say the same thing. I've tried formatting a flash drive, but nothing changed. The flash drives work on other machines. It's really strange and I have no clue what's going on. I'm by no means computer illiterate, but I've been unsuccessful in finding any remedies or information about the issue. I would greatly appreciate any assistance. Thanks!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    How is the drive formatted? If it is NTFS, OS X cannot write to that drive natively. See below for details on how to accomplish this.

    Format A Hard Drive Using Disk Utility (which is in your /Applications/Utilities folder)
    Choose the appropriate format:
    HFS+ (Hierarchical File System, a.k.a. Mac OS Extended (Journaled) Don't use case-sensitive) NTFS (Windows NT File System)
    • Read/Write NTFS from native Windows.
    • Read only NTFS from native Mac OS X [*]To Read/Write/Format NTFS from Mac OS X, here are some alternatives:
      • For Mac OS X 10.4 or later (32 or 64-bit), install Paragon (approx $20) (Best Choice for Lion and later)
      • For 32-bit Mac OS X, install NTFS-3G for Mac OS X (free) (does not work in 64-bit mode)
      • For 64-bit Snow Leopard, read this: MacFUSE for 64-bit Snow Leopard
      • Some have reported problems using Tuxera (approx $36).
      • Native NTFS support can be enabled in Snow Leopard and Lion, but is not advisable, due to instability.
    • AirPort Extreme (802.11n) and Time Capsule do not support NTFS
    • Maximum file size: 16 TB
    • Maximum volume size: 256TB
    • You can use this format if you routinely share a drive with multiple Windows systems.
    exFAT (FAT64)
    • Supported in Mac OS X only in 10.6.5 or later.
    • Not all Windows versions support exFAT. See disadvantages.
    • exFAT (Extended File Allocation Table)
    • AirPort Extreme (802.11n) and Time Capsule do not support exFAT
    • Maximum file size: 16 EiB
    • Maximum volume size: 64 ZiB
    • You can use this format if it is supported by all computers with which you intend to share the drive. See "disadvantages" for details.
    FAT32 (File Allocation Table)
    • Read/Write FAT32 from both native Windows and native Mac OS X. [*]Maximum file size: 4GB.
    • Maximum volume size: 2TB
    • You can use this format if you share the drive between Mac OS X and Windows computers and have no files larger than 4GB.
     
  3. Surfmavs macrumors newbie

    Joined:
    Jun 28, 2007
    Location:
    Merida Yucatan Mexico
    #3
    Sqme problem.. Writing to HDD

    The other day i had the same problem, i couldn't save a word ocument i got send, created by someone else, but edited by me. I thought it had something to do with file permissions, and ended up exporting it to pdf. Could it be a document infected by malware? The sender is not a really tech savvy person using windows...

    Then i tried to save a new document and it did without hiccups...
    Good luck!
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    No, it's not malware-related, as there are only a few OS X Trojans in the wild, none of which cause the symptoms you described.
     
  5. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #5
    If you save the file to a folder on your hard drive, can you then copy it over to the flash drive OK? Can you save directly to the flash drive from non-Microsoft programs? You implied some things but didn't state explicitly.

     
  6. bkkusc thread starter macrumors newbie

    Joined:
    Oct 25, 2013
    #6
    I just tried this today and I can move the file from the folder to the drive, however when I try to open it, I get the error: "There was an error accessing /Volumes/(flash drive name)/file name.

    This happens with any of my flash drives and they all used to work. Ugh!! Not sure what's going on.

    ----------

    The drive is FAT32 and I've tried formatting one of my drives and the problem still occurs.
     
  7. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    I realize this isn't the ideal solution, but might be worth trying.

    1. Move files/folders in question from flashdrive to your Mac's hard drive.

    2. Work on the files that way.

    3. When finished, move the completed files/folders BACK TO the flash drive.

    Whatever works, works....
     
  8. bkkusc thread starter macrumors newbie

    Joined:
    Oct 25, 2013
    #8
    That really won't help me, I need to save new files on to the flash drives. I might try removing microsoft office and re-installing, we'll see how that goes.
     
  9. bkkusc thread starter macrumors newbie

    Joined:
    Oct 25, 2013
    #9
    I completely uninstalled all of microsoft office 2011 and reinstalled it. This did not solve the problem. I'm attaching two images that show the different error messages. The first image shows the different error messages from word, excel and powerpoint when I try to save to a flash drive. the second image shows the errors I get when I save a file to a folder, move the file onto the flash drive, then try to open the file. Hopefully someone out there has some suggestions.

    Thanks again for any help!
     

    Attached Files:

  10. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #10
    Try a different flash drive.

    Does the problem still occur?
     
  11. bkkusc thread starter macrumors newbie

    Joined:
    Oct 25, 2013
    #11
    Yes, I have tried at least 5 different flash drives
     
  12. bkkusc thread starter macrumors newbie

    Joined:
    Oct 25, 2013
    #12
    Just to update everyone, I did a clean install of Mavericks and installed Microsoft office. The problem seems to be fixed now. I still have no clue as to what was causing the problems. Thanks for all your suggestions.
     
  13. sbabolat macrumors newbie

    Joined:
    Jul 18, 2011
    #13
    Old thread, but same issues as the OP. Cannot open/save office files from a flash drive. Tried on my mac air, it is fine.
    Opening and working in file from the imac directly is fine too.

    I uninstalled and reinstalled office, but same.
    Reinstalled maverick, same.

    OP: did you completely remove office, then reinstall maverick, then installed office?
     
  14. bkkusc thread starter macrumors newbie

    Joined:
    Oct 25, 2013
    #14
    I installed a brand new SSD with a fresh install of mavericks and everything worked well for a short amount of time and then went right back to malfunctioning as I described earlier. I'm just living with the problem at this point and just hoping this problem will disappear when I replace my macbook. Sorry I don't have any solution for you.
     
  15. smartprotech, Sep 20, 2014
    Last edited: Sep 20, 2014

    smartprotech macrumors newbie

    Joined:
    Sep 20, 2014
    #15
    I had the same issue. Only MICROSOFT files had this issue. unable to save or open any MICROSOFT item (word, excel etc)

    Problem: My mac hard drive and USB hard drive had the same NAME so I erased the USB drive with different Name. now it works prefectly no issue. DEFECT in MICROSOFT i think.
     
  16. DION_ macrumors newbie

    Joined:
    Feb 19, 2017
    #16
    smartprotech, Thank You. This seems to be the answer. I changed my internal hard drive name to something other than my external where the file was coming from, and Blamo. Worked instantaneously.

    Thanks for taking the time to post the solution.
     
  17. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #17
    I find it amusing that folks will use different drives, and not give the drives their own distinctive names...
     

Share This Page