Problems scanning with HP printer and Mavericks

Discussion in 'OS X Mavericks (10.9)' started by ToddJ, Oct 11, 2013.

  1. ToddJ macrumors 6502

    May 23, 2008
    I recently installed the GM version of Mavericks and tried to scan some stuff and it came up with this error "An error has occurred saving the file because it could not be written to. Check the properties for the file to make sure it is not read-only." I tried repairing permissions and reinstalling the scanner software, but to no avail.....I'm not certain if it is because of Mavericks or something unrelated to that...any suggestions?
  2. zaxcom macrumors newbie

    Sep 23, 2012
  3. Damama macrumors newbie

    Oct 23, 2013
  4. squeakr macrumors 68000


    Apr 22, 2010
    There is a new HP software driver for Mavericks. It doesn't always show up for a whole in updates but it is there. That may solve your issue. I did an in place upgrade and have had no issue with my HP all in one, scanning or printing. Of course I reset my network and reinstalled the printers as well.
  5. alfansome, Oct 23, 2013
    Last edited: Oct 23, 2013

    alfansome macrumors member

    Dec 29, 2012
    what do you mean by "in place upgrade"? Are you referring to how you upgraded OS X or that you were able to somehow download a new HP driver for Mavericks?

  6. squeakr macrumors 68000


    Apr 22, 2010
    In place is the standard upgrade where the new OS is run over the top of the existing os. This would be the way most upgrade by downloading and installing from the App Store and no files or settings are lost this way. The other way would be a new/ clean install which is effectively wiping the drive and the. Installing a new copy of OS. All files and settings eol be lost this way.

    And yes, there is a new driver, it just popped up on one of my other systems after about a day after the upgrade. It is a newer HP driver that is better designed for Mavericks supposedly.
  7. alfansome macrumors member

    Dec 29, 2012
    ok; thanks for the clarification. In my case, after upgrading from the app store, the HP Scan program no longer worked properly (regular printing was not affected). I had to reinstall the (original) HP Software. There were several error messages during the install about a kext file not able to be installed, but the scan does (mostly) work.
  8. davideotape macrumors 6502

    Nov 16, 2012
    i have an hp all in one and a neatreceipts portable scanner and neither of them are working since the upgrade :(
  9. alfansome macrumors member

    Dec 29, 2012
    does the print function not work also? or just the scanning? If you have the software install disc you might try re-installing it. In my case, there seemed to be some file permissions that weren't appropriate for Mavericks and so re-installing seemed to correct that (although I had to install it twice, the first time it only went part way and then stopped with an error - its probably cleaner to uninstall it and then reinstall it).
  10. jont-fu macrumors regular

    Mar 13, 2008
    Yeah I have the same problem.

    Luckily I had a virtual machine of my old Windows XP installation and could run the scanner software there.
  11. la-dee-dah macrumors newbie

    Oct 6, 2013
    having the same issue..... this is so frustrating
  12. mfram macrumors 65816

    Jan 23, 2010
    San Diego, CA USA
    This is interesting. I just acquired an HP 425dn all-in-one this week. I can print and scan from the device just fine in Mavericks. This is a network attached printer/scanner if it matters, not USB.

    I was not using the device previously in Lion/ML because I just got it. There was an HP Driver update that showed up under the App Store just recently. If your scanner isn't working, have you received an HP update recently? If not, maybe that's the problem.

    Oh, and I'm not using any HP Scan software. Instead, I found the HP on the "Printers and Scanners" page and clicked on the "Scan" button. It brings up a simplistic HP Scan utility. Maybe the HP software is broken but not the Apple software.
  13. xlii macrumors 68000


    Sep 19, 2006
    Millis, Massachusetts
    This is a real issue. I upgraded to Mavericks yesterday and after seeing this thread tried to use my G4050 HP scanner. I've had it for several years and has worked on 10.6, 10.7, and 10.8 OSX.

    Doesn't work on OSX 10.9. So I used google. Try HP scanner not working on Mavericks and you will see threads in the HP support groups and the Apple discussion groups on this subject. It looks like any HP scanner or HP all in one scanner no longer works.

    How did this slip by? Were HP scanners never tried on Mavericks or were they tried, the problem reported... and never fixed. Either way someone dropped the ball.

    PS The G4050 isn't some antique scanner. HP still sells it. It's their current offering in that price range.
  14. xlii macrumors 68000


    Sep 19, 2006
    Millis, Massachusetts
    I got my G4050 scanner to scan under Mavericks. I went to the HP website, went to the support site for the G4050 and downloaded the latest drivers for it which were from 15 July 2013 V1.3.0. The software said it worked under 10.6.8, 10.7, and 10.8... no mention of Mavericks. I tried it anyway.

    After installing it uses Image Capture to scan. Did a couple of test runs and it now works.

    So you might want to try uninstalling the old software first and installing the latest software from the HP website.
  15. Hans Hockx macrumors newbie

    Nov 2, 2013
    Schiedam, the Netherlands
    Same problem here with my Scanjet 8300. My temporary work-around is to call the HP scan utility from Photoshop. That way the scan will be transferred to Photoshop and can be printed from there.
  16. Eriamjh1138@DAN, Nov 4, 2013
    Last edited: Nov 4, 2013

    Eriamjh1138@DAN macrumors 6502


    Sep 16, 2007
    BFE, MI
    Scanner fixed using SANE

    I'm running an ancient Canon LiDE30 scanner that really hasn't been supported by Canon since Leopard (originally supported for OS9).

    I'm too cheap to by Vuescan for $80, which is the easiest solution.

    I used the SANE drivers from here:

    Downloaded and install the following (install libusbx first):
    libusbx, TWAIN SANE Interface, SANE Preference Pane

    Then you can access your scanner through the TWAIN interface. It may not be the greatest but it beats taking pics with my camera, aspect correcting them and cropping.

    Worked for me.

    Update: Preview doesn't appear to work, but it scans fine.

Share This Page