problems sending emails from iphone

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by psywzrd, Aug 14, 2008.

  1. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #1
    I have my pop gmail forwarded to my ".me" email address. I also have the outgoing server on my iphone set to gmail's outgoing mail server so that when I reply to a message from my iphone, it looks like it's coming from my gmail account. Anyway, it has been working great but I had to replace my 3G with a new one yesterday because the old one was giving me problems. Now when I try to reply to a message from my iphone I'm getting a message that says "Cannot Send Mail. The user name or password for SMTP:myusername@mail.optonline.net" is incorrect. I don't understand why this is happening. When I go into account settings for my ".me" account, my outgoing mail server is set to smtp.gmail.com, just like it should be; however, it looks like the Primary Server is set to mail.optonline.net even though it's off (I also forward my optonline.net email to my ".me" email address). If that primary server is off, why is it still trying to use it send email? And if it's saying that my username or password is wrong, why doesn't it give me a place to re-enter them? My messages are just sitting in my Outbox and it's driving me nuts. Mail.optonline.net shouldn't even be set up as the primary server - I have no idea how that got in there and I don't see a way to delete it. Please help!
     
  2. nctarheelfreak3 macrumors newbie

    Joined:
    Nov 16, 2008
    #2
    i have an optonline account and gmail accoun and something similar has been happening to me. No matter how hard I try everytime i send an e-mail it comes from my gmail account.

    i even deleted the gmail account on my phone, and the same thing is happening
     
  3. skd macrumors 6502

    Joined:
    Aug 27, 2006
    Location:
    carmel, ca
    #3
    i had the same thing happen - i reset the iPhone to its factory settings and it worked just fine.
     
  4. andyblila macrumors 65816

    andyblila

    Joined:
    Jul 8, 2008
    Location:
    On My iPhone, or my iPad?
    #4
    I ended up deleteting gmail from my iPhone due to the fact that it seems to monopolize the iPhone.
     
  5. NuMystic macrumors member

    NuMystic

    Joined:
    Dec 26, 2008
    #5
    Replying to this old thread because it came up first in my google search for this issue.

    I was having the same problem... tried all the other solutions floating around without success. (the captcha page, resetting password, and deleting then re-entering the account on the iphone)

    Finally on a whim, I deleted the account from my phone and this time ignored Gmail's instructions to use the "Other" option rather than "Gmail" on the iphone's new account screen. Voila! It's sending email just fine now.

    So in this case, it looks like Apple's "it just works" configuration trumps the official DIY approach endorsed by the Google Gods. Hope this works for you too!
     

Share This Page