Problems Sending Mail with gmail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ics2j2k, Apr 25, 2008.

  1. ics2j2k macrumors newbie

    Joined:
    Apr 25, 2008
    #1
    I have encountered a bizarre fault with my iPhone. I have been sending and receiving emails perfectly until yesterday.

    I am using a POP mailbox for my incoming mail and routing my outgoing mail via GMail. Mysteriously after a linked my iPhone to my computer to put some songs on it the sync erased the password details for my outgoing mail server. When I enter the password details it doesn't save them. So I can't send any mail as it doesn't connect to the server. When I go into advanced mail settings the option to ask for authentication is grayed over and isn't selectable. I'm guessing that this is the problem, and I don't now how to change this.

    I thought that it could be a glitch in the hardware so I did a full restore (twice!) and still the same fault. I have also tried deleting the email account and setting it up again. But each time after saving the outgoing password it erases it and says password is 'optional'.

    I have also tried resetting the network settings, but this hasn't worked either. For some reason when I re-enter all of the details for the outgoing server and save the information entered, it discards the password even after the save, I just cannot figure out why the password will not stick in the memory even after resetting. It classes the password field as optional but will not allow me to make this a necessary field.

    Any help would be greatly appreciated.
     
  2. Oceansized macrumors member

    Joined:
    Oct 29, 2007
    #2
    Set up the mail account using the 'Other' setting on the phone, rather than selecting GMail.

    When setting it up make sure you use O2's outgoing mail server, which is 'smtp.o2.co.uk'. It doesn't need a username and password. When setting up it will ask do you want to connect without SSL, select Yes. It will fail but save anyway.
    Go back to the settings of that mail account and in the advanced settings make sure both SSL's are OFF, and change the outgoing port from 587 to 25.

    This should now work fine.
     
  3. ics2j2k thread starter macrumors newbie

    Joined:
    Apr 25, 2008
    #3
    It didn't quite work, although I have got it working now thanks to your advice.

    I had originally set up the account with the 'other' option rather the Gmail. So I decided invert your advice and set one up with the Gmail function. (Although this isn't ideal for me as it won't send email from my domain name but from my gmail address). Anyway once I got this working I went back to my other faulty email account, and as mysteriously as the password field became optional it became a necessary field again, and I am sending email as I once was...

    I feel as if I almost had to trick the iPhone's settings to get it to do what I want, hopefully it sticks this time!
     

Share This Page