Problems setting up WD MyCloud Home

Discussion in 'iMac' started by Sill, Sep 26, 2018.

  1. Sill macrumors 6502a

    Joined:
    Nov 14, 2014
    #1
    I have a new iMac, final generation Airport Extreme, and I needed a large drive to act as a movie share for my Infuse setup. I spotted a 4TB Western Digital MyCloud Home for under $180 so I bought it.

    I've never set up a NAS before. There were no instructions in the box, just a card that looked like a bookmark with some basic art that apparently represents the router and the drive, along with an iOS device. There's a string of numbers on a sticker at the bottom, and thats all. No instructions.

    I plugged an ethernet cable in to the LAN port on the AE, and ran it to the new drive. Power up. It spun up, but thats it. Drive Utility showed nothing. Time Machine was able to see it down to the model number, but I wasn't going to use this for Time Machine. I need to clean 600MB of movies off my iMac, not duplicate the drive remotely. I saw there was a USB port on the back, so I hunted down the appropriate cable and connected the drive directly to the iMac, but that failed as well. That just doesn't make sense.

    I've been searching around on WD support, which is just about worthless. Everything I read is for people who want to use it as a remote backup for iOS devices, not for someone who wants an actual NAS. I just want this thing to serve movies locally, behind my firewall. If anyone can offer any help on how to use this as an external, non-backup volume I'd appreciate it.
     
  2. Krw999 macrumors newbie

    Joined:
    Sep 1, 2018
    #2
    Because its a network attached storage drive its a little different to a drive you would plug into the computer directly. Disconnect the USB cable - the USB port is so you can add an additoional drive or usb flash disk for extra storage.

    The drive should be connected via ethernet to your AirPort Extreme. On the iMac you should see the MyCloud name under the shared section of the finder sidebar. If not, you may have to connect to the disk and setup access permissions. You need to go to www.mycloud.com/setup and click the Get Started option. This will walk you through the setup including setting names, addresses, user accounts, etc. After this the drive should appear in the shared section of the finder.

    Hope this helps
     
  3. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #3

    It did, thanks. I always set up my new machines to mount volumes on the desktop so I can do most actions from there. I hadn't used the sidebar since Jaguar, probably. I found the drive under "Shared", which had my iMac and the MyCloud listed. I saw a "Connect As..." box, which I clicked on. A window popped up which said "Enter your name and password for the server "MyCloud". There was a tool beneath that which offered my radio buttons to connect as Guest or Registered User. Registered User was pre-selected, and my account name was already filled in.

    Thats where I'm stalled now. I thought it was asking me to set a password, but thats not it. Its looking for a logon. It isn't looking for my account password, because that doesn't work. I looked at the bookmark card with the unintelligible "instructions" on it, and at the bottom theres a sticker with a string of code and a little padlock next to it. Three groups of three characters, separated by dashes. I tried that with and without the dashes and no luck.

    Somehow a password got set on this thing, but I didn't do it. Maybe the drive is a refurb and WD didn't erase the previous data? Is there a way I can just reformat this volume and be done with this?
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    I don't own a WD drive, just going from what I've heard elsewhere, but....

    Does the WD drive have any factory-installed software?
    Stuff that "can't be removed" -- except by using special software from WD to do so?

    I believe that if you go to WD's site, you can download some kind of utility that will REMOVE all the factory-installed software.

    Once that's done, ERASE the entire drive using Disk Utility.

    Then... start over.
     
  5. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #5

    I'll check on that, thanks.
    --- Post Merged, Sep 27, 2018 ---
    I found a Downloads section under the support tab for the MyCloud Home device. That got me a program called WD Discovery. It keeps asking me to sign in to the drive! How can I sign in to the drive if I didn't set it up?

    This thing is going back.
     
  6. Krw999 macrumors newbie

    Joined:
    Sep 1, 2018
    #6
    The standard drive is set up with a username of admin and no password. You need to log into the system via Safari or other browser (try MyCloud.local or the IP address of the device in the address bar) and set up users and passwords yourself.
     
  7. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #7

    There is no IP address. I downloaded LanScan to be sure, and the only thing that shows up on the network is the iMac itself.

    I installed the WD Discovery app, which also pointed me towards WD Tools and WD Security. I installed both, thinking that something would be able to talk to this drive. None of those apps helped. I ran the Uninstallers for each of the three. Now the Shared section of my Finder sidebar is completely gone. Clicking on the iMac under Devices and going to Network also reveals nothing. The drive has now ceased to exist according to my network.
     
  8. Krw999 macrumors newbie

    Joined:
    Sep 1, 2018
    #8
    Its been a while but I don't remember doing any of that. I had a little card that said to go to http://mycloud.com/setup and it sorted everything out from there. It asked for user name, passwords etc. Maybe try the website tools again without using the software you downloaded
     
  9. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #9

    I saw that. Its asking me to set up a cloud account to use a local drive?
     
  10. Krw999 macrumors newbie

    Joined:
    Sep 1, 2018
    #10
    It does, although you don't have to use it. You can select whether to allow the disk to be shared over the internet or not once you get the unit up and running. It makes it easy to share and access the drive whilst away from home but I've always turned it off

    I think you have to set it up though before it lets you go any further
     
  11. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #11
    The problem is, once that account exists, it never goes away. It also presents a back door for unauthorized access.

    I think its time I looked at other products. Are you aware of any home NAS gadgets that allow a person to simply share behind their firewall, without any kind of cloud account?
     
  12. Krw999 macrumors newbie

    Joined:
    Sep 1, 2018
    #12
    I use a two bay Synology DS212J and a 4 bay WD MyCloud PRO 4100 as well as the single bay MyCloud. The Synology doesn't ask for cloud accounts but both the WD do.

    Everything on the WD drive is password protected and if you don't allow the drive to be used over the internet (on the local drive management page) it doesn't open the ports on the router so it should be safe. The cloud account stays on the WD servers but until you tell the local drive to use it then it doesn't link the two together. You then manage the drive through the local dashboard rather than having two use the cloud account again.

    I've tried port scanning, etc. and not managed to find the drive, and then if you turn internet sharing on it suddenly appears.
    --- Post Merged, Sep 27, 2018 ---
    Another thought, does you router have a USB port that you can simply plug a USB external HDD into and then it will be shared across your network without needing any NAS
     
  13. Sill, Sep 27, 2018
    Last edited: Sep 27, 2018

    Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #13
    I brought that up here about a year ago, in a home theater thread. I was told that it couldn't be done that way for some technical reason. Maybe it was for throughput, I don't know. I have the last Airport Extreme, which does have a USB port on it, and I bought a My Passport at the same time as the MyCloud Home, so I could try that.
    --- Post Merged, Sep 27, 2018 ---
    I turned on internet sharing with the drive plugged directly into the port on the iMac, and selected Ethernet, and the drive showed up again. Turned off sharing, the drive disappeared. I still wasn't able to access it. This thing is weird.
     
  14. Krw999 macrumors newbie

    Joined:
    Sep 1, 2018
    #14
    The usb disk in the AirPort Extreme should work fine. I’ve had My Passports plugged into them before without a problem. You may have to use Aiport Utility from your Mac to make the disk available and set any passwords
     
  15. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #15
    I'll give that a try. Thanks.
     
  16. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #16

    It was a hassle but I got it working. Probably the most un-Maclike experience I've had in years. I had to reformat the drive - can't return it now - but I built two partitions out of the 3TB drive. One was 2TB as that is double the space of my iMac drive, and the other 1TB will be my media storage. It took a couple of hours to get everything moved over.

    After plugging the thing in, of course it didn't show up. I spent a lot of time trying to figure out what was wrong but eventually found that I had to go into the Disks section of Airport Utility and enable sharing with a device password. Then cycle the power on the drive. It finally showed up.

    Now I have to figure out how to get Infuse pointed at this thing. :(
     
  17. droog Suspended

    droog

    Joined:
    Apr 10, 2018
    #17
    This entire thread hurts my brain. You bought what is essentially a second computer to manage files and have managed to turn it into a network drive. The guy telling you to delete all the software off the NAS? SUPER CRINGE. Quite simply, throw the airport in the trash and buy a modern router. Buy a giant usb drive and your 100% where you need to be.
     
  18. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #18

    Essentially a second computer? For under $180? I doubt it. Its just a bottom of the line NAS. I can't even get into the thing to delete any software in the first place.

    And what's wrong with the Airport? Its the most recent generation, it has fantastic throughput and s/n and its never let me down. I've recommended to people that they go buy them while there's still NOS out there. What exactly should I be getting to replace it?
     
  19. droog, Sep 27, 2018
    Last edited: Sep 27, 2018

    droog Suspended

    droog

    Joined:
    Apr 10, 2018
    #19
    Pulled directly from the wiki:

    https://en.wikipedia.org/wiki/Network-attached_storage

    _________________________________________________________________________________________________
    A NAS unit is a computer connected to a network that provides only file-based data storage services to other devices on the network. Although it may technically be possible to run other software on a NAS unit, it is usually not designed to be a general-purpose server. For example, NAS units usually do not have a keyboard or display, and are controlled and configured over the network, often using a browser.[3]

    A full-featured operating system is not needed on a NAS device, so often a stripped-down operating system is used. For example, FreeNAS or NAS4Free, both open source NAS solutions designed for commodity PC hardware, are implemented as a stripped-down version of FreeBSD.

    NAS systems contain one or more hard disk drives, often arranged into logical, redundant storage containers or RAID.

    NAS uses file-based protocols such as NFS (popular on UNIX systems), SMB/CIFS (Server Message Block/Common Internet File System) (used with MS Windows systems), AFP (used with Apple Macintosh computers), or NCP (used with OES and Novell NetWare). NAS units rarely limit clients to a single protocol.
    _________________________________________________________________________________________________

    Yes, you paid 180 dollars for a computer. (maybe price doesn't play into a devices classification) That account you don't want to make? HOW ELSE DO YOU PLAN ON LOGGING INTO A COMPUTER IF YOU DON'T HAVE AN ACCOUNT.

    Head still hurts.

    Go make your account or don't use that computer.

    Don't take this personally, but I don't really feel like debating the merits of routers with somebody who didn't realize what they bought nor take the time to research what they actually bought. I mean, I'm not exactly a genius buuuuut.....
     
  20. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #20

    If you want to be technical about it, a NAS is an embedded system. A computer is more properly a general purpose device. Keep studying Wikipedia, my little droogie.


    The account I don't want to make has nothing to do with logging in to the computer AND EVERYTHING TO DO WITH LOGGING INTO SOMEONE ELSES COMPUTER SOMEWHERE BESIDES HERE. I fail to see why I should have to run my personal data access through an outside server when this drive is sitting next to my router. I can admin my router via an app, and my previous router via a webpage served by that very router. I see no logical reason why I would need to use a server hundreds of miles away as a gateway for a hard drive, unless it was so the gateway company can monitor my data usage. And it happens to be exactly for that reason. Its hidden in their terms but its very explicit about what they're looking at.

    With all the rattling between your ears, I don't doubt it.

    The NAS? Its getting returned. I don't know what "computer" you're talking about.

    Yeah, you're kidding, right?

    Buuuut you'll jump into a thread to offer your opinion where it wasn't necessary, wanted or even productive.

    I bought what was recommended to me, here, on this very site. I originally wanted to get a USB drive and plug it into the router, but I was told here, on this very site, by an expert (much like yourself) that wouldn't work and I would need to get a NAS. I was told they were easy to use and had amazing throughput. So I bought a NAS. And found out that I need to compromise privacy in order to use the thing. I then found out that a simple USB 3.0 backup drive I purchased on the same ticket will work, exactly as I originally had wanted.

    So apparently I did my research and still came up short. Thats how you learn, boyo. When you grow up you'll figure that out. In the meantime, how about you go back to Wikipedia and study up on routers so you can come back here and talk about all the great features I could get if I would just throw away a $150 router that works perfectly. If you can find the time in between studying reviews on graphics accelerators, I mean.
     
  21. droog, Sep 28, 2018
    Last edited: Sep 28, 2018

    droog Suspended

    droog

    Joined:
    Apr 10, 2018
    #21
    You can't get a wd cloud drive working...and had no clue what you bought. Don't be mad at me. You bought a computer you aren't willing to learn how to operate. User error.

    You aren't logging in to anything other than the cloud device sitting right next to you via your home's network. The idea that you think it's being relayed across the web and back to your local network is HILARIOUS.

    Hey look!
    https://support.wdc.com/knowledgebase/answer.aspx?ID=18909

    It contains 256mb ram and a dual core 650mhz processor and has 4tb of drive space...but...I guess that's not a computer! lololol

    Anyways, stop taking forum users for granted and start learning about what you buy before you buy it. Maybe watch some install videos on youtube before you plonk down 180 bucks on a computer you can't be bothered to learn how to use.
     
  22. Sill thread starter macrumors 6502a

    Joined:
    Nov 14, 2014
    #22
    I was unwilling to learn how to operate it? Did you happen to read the entire thread? Aside from gently trying to school you on technical things - this whole time has been spent trying to learn how to get this drive working.

    Try aiming for a different spot on your "Jump to Conclusions" mat.

    I didn't say my data was going through their servers. I said my personal data access was going through their server. There is no physical or logical reason to require a person to authenticate their own hard drive, sitting in their own home or office, via a third party.

    https://support.wdc.com/knowledgebase/answer.aspx?ID=19625&lang=en
    https://support.wdc.com/knowledgebase/answer.aspx?ID=18896

    And here's one that deserves special consideration:
    Whats in the "One More Thing dialog box"?

    [​IMG]


    Note, it doesn't say "click on the link and see what the "product improvement program" is, it says "Select Continue" despite there being a nice link there for people to investigate. Not that it would really matter much because they've been notoriously vague, almost Google-like, about what information they're collecting through the "Product Improvement Program". But its still very revealing that they would tell people to click right past it. Is that because they don't want people thinking about what that program really does? Or is it because they know there's really no information there that explains the program? Many questions are posted about it on the WD forums, and all the responses from WD staff say it allows "WD to improve future updates by collecting information such as product serial number during a firmware upgrade". Their answers are what's known as "stock responses", aka "the company line".

    But really? Thats all they collect, the serial number? No, its not. They said "such as", which in legalese means "includes, but not limited to". Repeated requests for more information about the program generate no responses from WD reps past that single statement about collecting the serial number. Device firmware updates for many electronic devices already respond to serial information as that is the only way that the vendor can be certain they are providing the firmware update to an eligible device, and not potentially bricking an non-eligible device. Do you want to know what they're collecting? Here's a more correct, legal explanation. Note the absence of the weasel words, "such as":

    https://www.wdc.com/about-wd/legal/privacy-statement.html#products

    They're pulling metadata, along with location info. Metadata can actually be more revealing than actual file contents. Its one reason why initial investigations leading to indictments often rely strictly on metadata, not content. We're drifting off course here, but if you want me to get into forensics and law, I'd be glad to oblige you via PMs.
    Suffice it to say that a vast amount of information about a person can be derived from metadata. It can be likened to the difference between bit-mapped and vector-based images. The first gives you nearly every bit necessary to complete a precise image, whereas the second gives you the instructions on how to draw the image. Its a vast oversimplification, but perfectly adequate for our needs. Metadata gathering is just as much an invasion of privacy as if someone was staring in your window and watching you work on your computer.

    BTW: When I say "computer", I'm talking about the kind with a display, input devices such as keyboards and trackpads/mice, output devices such as displays and printers. I'm not talking about embedded systems, which can have quite sophisticated processors, RAM, and storage, yet lack meaningful I/O. Automotive ECUs, kitchen appliances, surveillance DVRs, game consoles - these all have quite a lot of processing and storage, but I can't think of a single person who would call them a "computer".

    Oh wait, there you are again:


    The first generation Xbox was a pretty serious machine, but no one called it a computer, it was a gaming console. Then people found out you could wipe it and install Linux. People still do that up to the current generation, don't they?

    https://itstillworks.com/12230981/how-to-turn-your-xbox-into-a-pc

    https://linustechtips.com/main/topic/89978-turning-an-xbox-into-a-computer/

    There are hundreds of articles and posts like this. Someone figured out how to attach a display and keyboard, and install a user-facing OS. It was a game console. It became a computer. Yet the hardware specs didn't change.
    People have done the same with all sorts of devices, and one guy actually got a minimal install of Linux to go to a boot screen on an old iPod. If he ever finished that project, he'd have a computer. Conditions need to be met. This is reality, not semantics.
    Until someone takes a NAS and installs a user-facing OS on it (not QTP or some other embedded Linux), and adds meaningful I/O, its still a NAS, despite you doing a component count on it.



    Maybe you should pay attention to the world around you and not get so focused on proving someone wrong that you end up embarrassing yourself.
     

Share This Page

21 September 26, 2018