Problems shutting down

Discussion in 'OS X Yosemite (10.10)' started by Ardmanz, Oct 20, 2014.

  1. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #1
    I've always had problems shutting down my rMBP, I believe it's something to do with a shared network drive.

    On Mavericks I would select shut down, the top bar would disappear but it wouldn't shut down. I'd then load up Safari, select shut down and it would then actually shut down. It would also shut down on the second attempt without fail.

    Now, after upgrading to Yosemite at least 50% of the time it will not shut down and all and it often locks up (non-responsive) so all I can do is hold the power button to shut down or restart.

    Anyone else having this problem?
     
  2. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #2
    Anyone else having this problem?

    I literally couldn't shut it down last night so it's just in standby. I don't want to keep holding the power button to switch it off in case it damages the SSD.
     
  3. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #3
    Not me. But I did have something suspiciously similar...

    Connected my MBP to a shared folder on a computer at work. Later, at home, when starting up iTunes, the logo would bounce up and down for a while. I'm pretty sure it was trying to scan a disconnected remote share, and giving it its best shot before eventually giving up. Didn't recur when I made sure I actively disconnected from the share before taking my laptop home.

    If you are sharing your drive, perhaps it won't release control until all clients are disconnected. If you are using someone else's share, did you disconnect manually first before shutdown?
     
  4. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #4
    Yes, it's shared and I am connecting to it.

    I will try disconnecting manually first. Is there anyway of automating this?
     
  5. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #5
    I tried disconnecting from the shared drive and it still doesn't work.

    I also (I forgot to mention this in my first post) am unable to open finder after I've tried to shut down. I get the "relaunch" option but it doesn't do anything so my only option is to hold the power button.

    My battery life is also much worse now.

    Yosemite gets a massive thumbs down from me at the moment. :(
     

Share This Page